4

I followed the instructions here to install tightvncserver onto my Pi so that I can connect to it from my PC.

However when I start it vncserver :0 and then connect, I get a horrible white/grey bar that flickers at the top of screen instead of the proper menu bar:

enter image description here

I've tried various combinations of -depth and -geometry but I cannot get the menu to properly appear.

Does anyone know how to correct this?

  • Have you tried a different VNC client to see if the problem persists there? I assume you ruled out that this flicker isn't happening if you plug in a physical monitor or TV? Did you try on HDMI and analog? – maple_shaft Jan 1 '16 at 17:53
  • I will say though that VNC isn't the most responsive user interface and other types of remote control tend to have better security and access controls. I would look into setting up X11 forwarding through an SSH client. This can be easily achieved on any Linux distro from a Windows machine with nothing more than Putty and Xming installed on Windows. It will perform better and you can better control user security and sessions than with VNC. – maple_shaft Jan 1 '16 at 17:58
  • @maple_shaft I tried the VNC client on my iPad and it has the same issue. I'm happy to try something else although, given that I use VNC on other Windows machines around the house, it would be great if the Pi could use the same software. – Richard Jan 1 '16 at 21:20
  • considering that you also want a graphical interface on your iPad as well then VNC sounds like your only option. It sounds like maybe a bug in the VNC server? What distro is this? Have you tried a different VNC server like TigerVNC? – maple_shaft Jan 1 '16 at 21:29
  • I just hooked it up to a screen and the flickering is there, which is odd because before it worked just fine. I guess my question is now how to fix that as it appears VNC is working :( – Richard Jan 1 '16 at 22:54
3

It looks like there is an audio and video group that your user must be a member of for this menu to appear correctly.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=118258

Try adding your user to the audio and video group and reboot. Sounds like this will resolve the flickering menu problem.

  • A good find but, sadly, adding pi to both groups and rebooting multiple times hasn't solved the issue. Some sites claim it has to do with the network panel but, predictably, their solutions haven't worked either. .xsession-errors reports issues with an openbox menu.xml and that volumealsa is unable to "find elements". – Richard Jan 1 '16 at 23:47
1

I had the same issue and I found the solution here: https://www.raspberrypi.org/forums/viewtopic.php?t=105829

I edited the /boot/config.txt

sudo vi /boot/config.txt

And added a line

dtparam=audio=on

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.