1

I am a total linux noob and I am trying to follow the directions here: http://www.penguintutor.com/linux/tightvnc to start VNC at boot.

I can type

sudo systemctl start tightvncserver.service

in terminal and tightvnc runs and I can use it fine.

In the guide it says to use to enable it at boot

sudo systemctl enable tightvncserver.service 

From another answer on stackexchange I tried

sudo systemctl daemon-reload && sudo systemctl enable tightvncserver.service

but it does not start at boot, my pi just starts normally and the vnc instance won't respond from a client.

Any suggestions?

  • You can add your start command to crontab to force it to start at boot. – Patrick Cook Jan 1 '16 at 22:29
  • This looks like it should work. Have you checked the file ownership & permissions? What does systemctl status show? I use the following raspberrypi.stackexchange.com/a/39374/8697 – Milliways Jan 2 '16 at 1:11
  • Status shows that it is enabled. If I run systemctl disable tightvncserver.service then it shows disabled. – gnfrazier Jan 2 '16 at 1:49
  • I attempted adding it to crontab for the pi user using @reboot systemctl start tightvncserver.service but it still won't start at boot. – gnfrazier Jan 2 '16 at 1:55
  • oh and status also says that it is inactive (dead) right after reboot. – gnfrazier Jan 2 '16 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.