1

So, here is some background:

I followed this lifehacker article, and switched 28r with 35r, in the helper command. (I have the 3.5 inch PiTFT screen from Adafruit, not the 2.8 inch version.) I got Kali 2.0 (the Pi 2 version) on my Raspberry Pi 2, which comes with XFCE (4.10).

Now, down to what the issue is:

I connected my Pi 2 to my TV. The startup output displays on the TV, so I know the connection is fine, and that the Pi recognizes the TV. After I logged in, I managed to navigate to the "Display" section in Settings, through using the tiny PiTFT. I then was surprised to only see the "default" screen in the "Display" section, considering the TV was still attached to the Pi (via HDMI).

So, I would like to know why my TV is not showing up in the "Display" section, and how to make it show up.

Any help would be appreciated.

If any more info is needed, please let me know.

1

You can only get output on one display at any time.

To display X on your HDMI screen you have to disable boot into gui and start X manually, specifying the output via /etc/X11/xorg.conf.d/99-fbdev.conf, e.g.

Output on HDMI: mv /etc/X11/xorg.conf.d/99-fbdev.conf ~

Output on PiTFT: cp ~/99-fbdev.conf /etc/X11/xorg.conf.d/

A full guide to Kali Linux on Raspberry Pi with Adafruit TFT and a gorgeous finger friendly touch menu can be found on the "Sticky Finger's Kali-Pi" site:

http://whitedome.com.au/kali-pi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.