When try to acceso to my raspberrypi2, with transmission-daemon up, get a error Unauthorized IP Address.

Acording manual, I've edited /etc/transmission-daemon/settings.json with

"rpc-authentication-required": true,
"rpc-bind-address": "",
"rpc-enabled": true,
"rpc-password": "mychain",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "transmission",
"rpc-whitelist": ",192,192.168.*.*",
"rpc-whitelist-enabled": true,

Edit a json file with daemon stoped, and after save changes, start.

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.
  • 1
    I think you may have a typo in the "rpc-whitelist" entry, I suspect it should be ",192.168.*.*" - is "localhost" i.e. the local machine where the software is running, and 192.168.x.x. is the set of Class C IP addresses reserved for LAN (which no self-respecting Modem/Router should pass out onto the WAN/Internet) - the first "192" has to be an erroneous entry IMHO. – SlySven Jan 3 '16 at 1:40
  • Soory,, i put "rpc-whitelist": ",192,192.168.*.*", but corrrect it's "rpc-whitelist": ",192.168.*.*",. My LAN it's Problen now it's other. – abkrim Jan 3 '16 at 7:59
  • Is it working now or not? BTW when writing comments it is worth it to take the time to check the spelling of your words is correct before you click "Add Comment" - you have plenty of time to write the comment - but it is only possible to fix smelling errors if you click on "edit" for a very short time afterwards - all in all it is better to get it right before you click to post the comment... 8-P – SlySven Jan 3 '16 at 17:19
  • This problem solved. Other solved on other hisotry.. now working my transmission on raspberrypi2. Thanks. – abkrim Jan 3 '16 at 19:20
  • 1
    Please consider taking the "edited and solved portion" above and rewriting it as an "Answer" - which you then can Accept! This helps in the general process of actually answering questions here (it improves the recorded "performance" of the site) - and will give you a better reputation which will give you more capabilities on this site. After all, the corrected entry could be of use for someone else trying to use the same software on their RPi systems. 8-) – SlySven Jan 3 '16 at 19:32


Correct line
"rpc-whitelist": ",192.168.*.*",
Incorrect line
"rpc-whitelist": ",192,192.168.*.*",
  • rpc-whitelist will also accept whitespace as well as commas: "rpc-whitelist": " 192.168.*.* ", – Ron K. Jan 9 '17 at 2:59

A common mistake I did is mistaken




The one to modify is

"rpc-whitelist": "192.168.*.*",
"rpc-whitelist-enabled": true, 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.