4

I want to a setup where my Raspberry Pi acts as a WiFi repeater, connecting to a WiFi network if available and rebroadcasting it's own network.

Home network; mobile hotspot with internet can come and go

In this way, my mobile hotspot could come and go, but the home computers would always be connected to their intranet. That way, the Pi would connect when the phone was in range and the home computers would have internet access without switch networks.

I've got the configuration worked out. In fact, I've already used this setup with my laptop's wireless card (the Atheros QCWB335). Now I'm looking for a usb transceiver that is supported by the Pi and is capable of simultaneous client/AP modes.

The output of iw list can be used to check for support (look for AP and managed together under valid interface combinations).

Can the "official" Pi wireless dongle do this? Can anyone verify another adapter with this capability?

  • Could someone with this (or another) adapter post the output of iw list? That's all I need to know if it's supported. – Robbie Wxyz Jan 2 '16 at 22:53
  • You will need two WiFi dongles: you can't switch modes client/AP while connected on either mode without loosing packets – fcm Jan 5 '16 at 11:04
1

Atheros based wifi adapter - TP-LINK TL-WN722N, would definitely solve your purpose of making wifi adapter work in dual mode. The driver should work out of the box on raspian or should be little effort to figure out and install the driver. You would however need other settings to being up vlan interface, etc.

1

I know this doesn't directly answer the question but I don't have enough rep to comment and I figured this would help anyone trying to do something similar.

Someone put together a great how-to on Github that works with the built-in wifi on a Raspberry Pi 3B using Jessie: https://github.com/peebles/rpi3-wifi-station-ap

For Stretch: https://github.com/peebles/rpi3-wifi-station-ap-stretch

I have personally tested Jessie version and it seems to work. One thing to note however is that the channel used in your hostapd.conf must match the control channel used by the WiFi AP you are trying to connect to. If that is a router it can usually be found somewhere on the router's config page or by running this command from your Raspberry Pi:

sudo iwlist wlan0 scan | grep "your AP ssid" -B 5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.