3

I'm trying to follow intructions found here (http://www.makeuseof.com/tag/how-to-turn-your-raspberry-pi-into-an-always-on-downloading-megalith/) on How To Turn Your Raspberry Pi Into An Always-On Downloading Megalith, but I'm stuck at the 3rd step (sudo fdisk /dev/sda).

The error I get is the following: fdisk: unable to open /dev/sda: No medium found and when I ls /dev I can see the sda there. Also, I can see my device in lsusb.

@joan ls -l /dev/sd* returns brw-rw---T 1 root floppy 8, 0 Jan 5 17:28 /dev/sda

enter image description here

What else should I do?

5
  • What is reported by ls /dev/sd*?
    – joan
    Jan 4, 2016 at 21:10
  • @joan It returns me /dev/sda
    – Alex
    Jan 4, 2016 at 22:02
  • 1
    Normally a disk would have partitions. Could you edit your question to show what ls -l /dev/sd* reports?
    – joan
    Jan 4, 2016 at 22:07
  • comment added @joan
    – Alex
    Jan 5, 2016 at 18:45
  • Have you tried looking in the /media/pi folder? Sometimes a drive may show up there instead, regardless if it is an HDD or Flash disk
    – tycrek
    Jul 4, 2016 at 16:01

3 Answers 3

0

I guess your flash drive is fried bricked. Try unplugging then re-plugging. If it's still the same, plug it into Windows. If Windows tell you Please insert a disk into drive [letter]:, it's most probably bricked.

If it works, reformat the flash drive on Windows as FAT32 using HP's utility (download link) then try it on the Pi again.


If my assumptions are correct (based on your screenshots, floppy user and Verbatim brand):

You can't use fdisk on a floppy disk.

0

Plug the USB drive into the Pi or another Linux computer or any computer booted with a live Linux DVD or USB.

Run lsusb as root (sudo lsusb) to see if the drive was recognized.

If recognized run sudo gparted to add an msdos partition table if necessary.

Then add the 50 meg fat32 boot partition and ext4 system partition per the article.

By using gparted you can skip over the fdisk commands.

Also, I would use sudo blkid to determine the uuid of the new USB ext4 system partition and use that in the /boot/cmdline.txt file substituting: root=PARTUUID=a12e43d9-02 for the root=/dev/sda1 that they call for in the article.

Of course your uuid will not be a12e43d9-02 but something else. In this way it will always find your partition no matter how many USB drives you have installed.

Do the same in the /etc/fstab file substituting /dev/sda1 with PARTUUID=a12e43d9-01 and /dev/sda2 with PARTUUID=a12e43d9-02

Again, your uuid will not be a12e43d9-02

Hope that helps.

0

It looks like your disk is ejected. This can happen if the disk receives the SCSI eject command from the system, or you have a separate adapter (e.g. USB->SATA, perhaps this one?) which is itself correctly connected to USB, while the SATA connector of the underlying HDD/SSD is not properly inserted. It's also possible that the disk is faulty in a way that it still reports correctly on the USB bus, but the media can no longer be accessed.

Try running sudo eject -t /dev/sda, or unplugging/replugging the disk. If there's a separate adapter, make sure the disk is plugged into it before you plug the adapter into USB. If you have a spare USB->SATA adapter, try replacing it. I have several cheap USB->SATA adapters, and some of them have already died.

Assuming you have nothing useful on the disk, try resetting the partition table with sudo dd if=/dev/zero of=/dev/sda bs=1M count=1, and if it reports a success, try running sudo fdisk /dev/sda again.

It's also possible that your drive has an issue with UAS, only instead of being very slow it won't work at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.