0

I'm using my Raspberry Pi (Model B) and after I used the command startx on the LXTerminal it went straight to graphic interface. I tried to reboot back to my old desktop, but now it was asking for a login that it has never asked before after the initial booting.

I used the default login which is pi:raspberry. Then I used the startx command again in hope of exiting out of it through ctrl+alt+f1. It displayed the error: xauth: timeout in locking authority file /home/pi/.Xauthority and I think I corrected it. Now I'm trying to make my Raspberry Pi perform autologin by accessing sudo nano /etc/inittab and make 1:2345:respawn:/sbin/getty 115200 tty1 into a comment by putting a pound sign right before it and saving the changes.

Now I have rebooted the pi and it has stayed on a blinking cursor ever since not allowing me to do anything. Any solutions?

1
  • Nevermind! I figured it out! – Caro Jan 5 '16 at 0:28
1

sudo raspi-config

In menu:

Boot Options -> Enable Boot to Desktop/Scratch

To add automatic login, in /etc/inittab on tty1 add a line such as:

1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1 # RPICFG_TO_DISABLE

0

I was able to solve the problem by using the command sudo chown -R pi:pi /home/pi. This gave access back to the local pi user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.