7

So as my title suggests I am having an issue with my Retropie installation. I am currently using latest greatest BerryBoot, OpenElec, and Retropie on my Rasp Pi 2 updated as of yesterday evening.

The audio works perfectly if I am on OpenElec watching a movie. Soon as I load up my Retropie though the audio constantly goes in and out. I tried a number of suggestions already including adding "hdmi_drive = 2" to my core pi configuration file, forcing specific drivers for Retropie audio, and suggestions found on http://elinux.org/R-Pi_Troubleshooting#Sound.

Nothing seems to change the intermittent audio loss. I don't have any custom settings other than what I attempted with the troubleshooting listed above. Any additional help is greatly appreciated. I have a Samsung Smart TV but a friend has the exact same issue with his setup using his Vizio.

EDIT: Some additional information. The audio is dropping in and out within the Emulation Station menus as well. For example if I hold the direction pad button down in the ROM list you get a clicking noise but it goes in and out. Below is my RetroArch config (only the audio section was modified from stock). Also, my config.txt has only three modifications to it at the end of the file. They are the addition of hdmi_drive=2, hdmi_group=1, and hdmi_force_edid_audio=1.

#### Audio

# Enable audio.
# audio_enable = true

# Mutes audio.
# audio_mute_enable = false

# Audio output samplerate.
# audio_out_rate = 48000
audio_out_rate = 44100

# Audio resampler backend. Which audio resampler to use.
# Default will use "sinc".
# audio_resampler =

# Audio driver backend. Depending on configuration possible candidates are: alsa, pulse, oss, jack, rsound, roar, openal, sdl, xaudio.
# audio_driver = alsa
audio_driver = sdl

# Override the default audio device the audio_driver uses. This is driver dependant. E.g. ALSA wants a PCM device, OSS wants a path (e.g. /dev/dsp), Jack wants portnames (e.g. system:playback1,system:playback_2), and so on ...
# audio_device = hw:0,1
audio_device = hw:0,1

# Audio DSP plugin that processes audio before it's sent to the driver. Path to a dynamic library.
# audio_dsp_plugin =

# Directory where DSP plugins are kept.
# audio_filter_dir =

# Will sync (block) on audio. Recommended.
# audio_sync = true

# Desired audio latency in milliseconds. Might not be honored if driver can't provide given latency.
# audio_latency = 64
audio_latency = 256

# Enable audio rate control.
# audio_rate_control = true

# Controls audio rate control delta. Defines how much input rate can be adjusted dynamically.
# Input rate = in_rate * (1.0 +/- audio_rate_control_delta)
# audio_rate_control_delta = 0.005

# Controls maximum audio timing skew. Defines the maximum change in input rate.
# Input rate = in_rate * (1.0 +/- max_timing_skew)
# audio_max_timing_skew = 0.05

# Audio volume. Volume is expressed in dB.
# 0 dB is normal volume. No gain will be applied.
# Gain can be controlled in runtime with input_volume_up/input_volume_down.
# audio_volume = 0.0
audio_volume = 10.0

hdmi_group=1
hdmi_mode=4
  • I think the term for "goes in and out" is "dropping-out" but I guess no matter what it is called it is a pain... – SlySven Jan 6 '16 at 22:51
  • I too have the same issue with latest retropie for pi zero - audio is working within kodi (I'm using the plugin directly from within retropi) but it's "not-working" within emulation-station and emulators or for some unknown reason it is working. – pastacool Jan 13 '16 at 23:07
  • I wonder if it has something to do with TVs using 1080p because a friend has the same issue on his 1080p TV but not his 720p TV. – MAllen22842 Jan 14 '16 at 20:53
  • @MAllen22842 I get the same issue sometimes with OSMC running on B+. When I play the same file using a hardware decoder, the audio is fine. – Chetan Bhargava Feb 23 '16 at 3:57
  • My fix for this was buying a better power adapter and a good(read non ebay chinese usb cable) to power the pi. I almost never have an audio stutter anymore. – Dr_Bunsen Mar 16 '17 at 16:44
3

I had this same problem on my Vizio. There is nothing wrong with your Pi: this is a Smart TV "feature". They call it volume leveling and it is on by default. You should be able to turn it off from your audio menu. On my Vizio, I press the menu button -> audio -> volume leveling (3rd option down). Hope that helps.

0

I think the problem could be with Berryboot.

Have you checked that a SD card with just RetroPie installed works as expected? If it does we know the problem is with Berryboot. Was RetroPie installed using the Berryboot menu and downloading the OS from the internet, or did you convert a .img file to squashfs? If its the latter, you may want to try using the Berryboot menu to download RetroPie, its more likely to work.

If a single installation of RetroPie still has sound issues, then it is either a problem with RetroPie itself, or less likely, the Pi or TV. If this is the case you could try using a different TV just to be sure its not the problem.

From my understanding of the question your transmitting sound from the Pi to the TV using HDMI, have you tried using a 3.5mm audio cable for sound instead?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.