I've been using my raspberry pi as an XMBC media centre to stream video from a NAS box (via ethernet). It was working ok for the most part but recently it's been crashing out during playback.

I have OpenELEC XBMC installed (formerly has raspbmc - same issue) with the latest build. I've been playing 720p video without DTS audio (I've had other DTS skipping issues but that's another story).

The crash happens during playback from an SMB mounted network location, the screen kinda flickers (like a graphics chip glitch on a PC) and then goes black. The network lights turn off leaving only the single red light on. I can't ssh to the pi and it doesn't respond to key presses.

I have tried the following:

  • checked the power supply (tried 2 others) and am confident they all match the required spec (1amp / 5V). - issue still occurs
  • heatsink on the main cpu - issue still occurs
  • removed USB keyboard - same issue
  • playback direct from a USB drive, ethernet unplugged - works ok!

Therefore I belive the ethernet chip is causing the problem - it gets slightly warm but not hot. Anybody got any ideas on what the root cause may be? Anything I can try?

The ethernet is connected directly to a powerline adaptor and the pi is not overclocked.

1 Answer 1


Well, I have the exact same problem. The only solution that I have found is to use NFS. On windows, you can use hanewin. This tutorial is working great: http://www.sysprobs.com/configure-set-nfs-share-windows-7-ready-storage-vmware-esx

No more crash!



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.