2

I have a Wi-Fi adapter (the chip is Realtek RTL8192EU) which I use with my Raspberry Pi 2. I first tried using it with Raspbian Jessie (based on Debian 8), but the driver was not installed by default and although I have read a lot of posts about this issue, but they did not work for me. At that moment I gave up.

Later I discovered that on OSMC the right driver for my chip is installed by default, and I have been using OSMC for a while now. My Raspberry Pi Zero arrived yesterday, and I would now like to use the Zero with the Wi-Fi adapter on Raspbian.

Would it be easy to find out which driver my adapter uses on OSMC and then move that module to Raspbian and how would I find the right module?

This is the output of lsmod:

Module                  Size  Used by
cfg80211              542368  0
rfkill                 22502  2 cfg80211
uinput                  9818  1
8192eu               1149759  0
sg                     23797  0
uas                    15902  0
joydev                  9713  0
evdev                  11627  4
lirc_rpi                9315  3
bcm2835_thermal         2844  0
bcm2835_gpiomem         4026  0
bcm2835_wdt             4081  0
lirc_dev               11576  1 lirc_rpi
uio_pdrv_genirq         3885  0
rc_core                25681  1 lirc_dev
uio                    10364  1 uio_pdrv_genirq
fuse                  106878  1
ipv6                  441571  48
0

Oke, it has been a while and I completely forgot about this question, but this is how it turned out: the WiFi dongle ended up in the junk-drawer... After some effort I was able to find the right sources for the dongle and tried to compile them on Raspbian. That is the moment I found out why it worked on OSMC and not on Raspbian. OSMC is build with a much older kernel then Raspbian is and it used a lot of functions that where deprecated and removed in the newer Raspbian kernel. I have run into this sort of problem before and was able to replace the deprecated functions with a simple search and replace, but that wasn't an option here and modifying the driver for the newer kernel was going to take a LOT of work, so I bought another WiFi dongle for my Rpi and "archived" :) this one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.