I have read in many places that certain USB problems are mitigated by adding dwc_otg.speed=1 to the cmdline.txt (I added it after the first parm, which is also a dwc_otg setting). This is the only change I've made to cmdline.txt.

(The problems I am having relate to USB sound unit, but I'll save them for another question. My understanding, is that that problem can be helped by reducing the USB speed).

When I add dwc_otg.speed=1 to the cmdline.txt file, I end up with a broken USB.

  • Tried on October 28 Wheezy
  • Tried on Oct28 after doing a full upgrade yesterday
  • Tried on Dec16 wheezy, basically 'out of the box' (installed mpg321 only)

I have a 'rev 2'. no overclocking

In each case the result is the same: Pi boots, appears fairly normal, lists some USB detection info, and goes to login prompt, but keyboard is dead. Not even lights. Mouse is dead (no light). Even if I boot cold with just the keyboard, no function.

The network is also non-functional since I can't ssh into the unit. There's actually an error message towards the end of the boot which probably relates to this, and sshd takes longer to start than usual.

So, what is the situation regarding this parameter? Is there some other change I need to make to cmdline.txt? For, me, after a fair bit of trying, I've seen no effect ever from this change, other than to make the whole USB non-functional, which is very puzzling since it's been discussed a fair bit on the forums.


2 Answers 2


speed=1 can break compatibility with keyboards, I was not aware of this.

So, to make this work, find a compatible keyboard, and don't rely on the compatibility list http://elinux.org/RPi_VerifiedPeripherals

Presumably this may apply to mice, hubs, etc.

I was using a Microsoft Comfort Curve 2000, which is listed as a 'working keyboard'.

This keyboard works without speed=1. I have found it to be flaky when I overclock the pi, and completely incompatible with speed=1. I tried an ASUS keyboard which also fails when speed=1.

If I remove this keyboard I can get it to work, verified by SSH connect. I also have a Creative Labs usb sound device, and an ultimarc I-PAC connected via a hub. All that seems to worl. So, all I need to do now is find a keyboard & mouse that work with speed=1. Will update when I find them.

Update: Jan 6 2013, I've found that I can plug a PS/2 keyboard into the I-PAC 'aux keyboard', plug the I-PAC USB into the Pi, and that works fine. Not quite the same as having a separate keyboard, but good enough for now. Also, no surprise, a USB mouse that normally works fine also breaks things when speed=1.

Still would like to know of any compatible keyboards (and mice) and please add any 'non-compatible' keyboards you find in the comments.

  • List of keyboards I've tried: (1) Microsoft ComfortCurve 2000 (2) Asus PK1100U (3) Logitech Internet 350 keyboard. None of these work at all with speed=1
    – greggo
    Commented Dec 24, 2012 at 17:18
  • I'm having the same problem. I need speed=1 for my bluetooth adapter to work, but it breaks my keyboard.
    – ScArcher2
    Commented Dec 29, 2012 at 6:27
  • @ScArcher2 - keyboard make & model for the record, please... verify it doesn't work with only the keyboard plugged into USB
    – greggo
    Commented Dec 29, 2012 at 15:46
  • I've tried a Dell Keyboard as well as Microsoft Natural Keyboard Pro. It was the only thing plugged in.
    – ScArcher2
    Commented Jan 3, 2013 at 21:36
  • Since speed=1 limits USB to 1.1, you could try using USB 1.1 keyboard. You might also try connecting all devices through USB 1.1 hub. It's all just a speculation and I didn't test that, however. Commented Jan 8, 2013 at 8:27

I found a keyboard that works. Microsoft Wireless Desktop 800. For sale almost everywhere i guess. Gives you a working mouse too! Actually, it ONLY works with dwc_otg.speed=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.