2

Yesterday, I was programming GPIO controls for a robot in class and left for a few minutes to work with another group. I came back to find all the GPIO disconnected and sh: can't access tty; job control turned off on the screen.

So far, I have tried to reformat the SD card, used a different SD card, and typed disablesafemode into the recovery.cmd file. Nothing has worked so far.

Any suggestions?

  • How were you programming your GPIO pins? Python, shell, low level c? And what led to the can't access tty error? Running a script ? – Brett Reinhard Feb 25 '17 at 1:40
  • It's useless to bump this question because good answers would need more input from @user39770 who was "Last seen Jan 20 '16 at 18:19". Is there a way to tag questions as "probably unanswerable" or "needs input from question owner"? – yeti Jan 22 '18 at 11:48
0

You may be damage you RPi. Did you tried SD cards at another RPi? I lived this problem before but in my case just GPIO pins wasn't working and i bought new RPi.

I suggest try your SD card on different RPi and if working you might be damaged. If not working re-download Noobs from https://www.raspberrypi.org/downloads/ and try at working RPi before and after try your corrupted one.

SFMBE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.