0

NOTE: This is a duplicate from stack overflow. As I haven't got any responses there, I am reasking it here in hopes that because this is a RasPi-specific forum I'll get an answer.

I have a Raspberry Pi 2 with retropie installed. I use cwiid to pair a wii remote with classic controller attached, to my Pi. I used to be able to use the analog sticks in games like Rebel Assault in DOSBox. Now whenever I boot up or use my attachwii.sh script to connect the wii remote, I get the following message:Warning: duplicate absolute axis assignment. I can ctl-c out of the script and thee wii remote pairs fine. I can use the d-pad in Emulationstation but in dosbox, the analog sticks can't be used, even trying to map them doesn't work. Currently, it seems that the joystick controls are bound to the d-pad, and the mapper does not recognize the analog stick. Additionally, when I log in via ssh my console is flooded with a Socket connect error (control channel) error (this is actually a known issue, but I can't seem to carry out the fix.)

mywminput:

Classic.Dpad.X = ABS_X
Classic.Dpad.Y = ABS_Y
Classic.LStick.X = ABS_HAT0X
Classic.LStick.Y = ABS_HAT0Y
Classic.RStick.X = ABS_HAT1X
Classic.RStick.Y = ABS_HAT1Y
Classic.A = BTN_A
Classic.B = BTN_B
Classic.X = BTN_X
Classic.Y = BTN_Y
Classic.Minus = BTN_SELECT
Classic.Plus  = BTN_START
Classic.Home  = BTN_MODE
Classic.L  = BTN_TL
Classic.R  = BTN_TR
Classic.ZL = BTN_TL2
Classic.ZR = BTN_TR2
Wiimote.A       = BTN_A
Wiimote.B       = BTN_B
Wiimote.Dpad.X      = -ABS_Y
Wiimote.Dpad.Y      = ABS_X
Wiimote.Minus   = BTN_SELECT
Wiimote.Plus    = BTN_START
Wiimote.Home    = BTN_MODE
Wiimote.1       = BTN_X
Wiimote.2       = BTN_Y
Plugin.led.Led1 = 1

attachwii.sh:

#!/bin/bash
hcitool dev | grep hci >/dev/null
if test $? -eq 0 ; then
   sudo wminput -d -c  /home/pi/mywminput 2C:10:C1:1B:88:1D 
else
    echo "Blue-tooth adapter not present!"
    exit 1
fi
  • 1
    Please remember not to cross post questions across SE sites, as it is frowned upon on SE. Please see meta.stackexchange.com/questions/64068/…. It is better to ask for your question to be migrated. However, I understand why you did, and it is good that you finally have an answer. BTW, I have flagged your previous question on SO for deletion. – Greenonline Apr 7 '16 at 2:52
1

I can't remember how I got to this, but I solved the flood issue by adding -q before the path to mywminput and then adding > /dev/null 2>&1 & at the end as you can see.

wminput -d -q -c  /home/pi/mywminput 2C:10:C1:1B:88:1D > /dev/null 2>&1 &
  • Solved the duplicate absolute axis assignment problem, however dosbox still does not recognize the classic controller's analog sticks. I have deleted the SO version of this question. – user3832611 Apr 10 '16 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.