I could connect Raspberry Pi (10.0.1.39), however, I cannot make it found from my Mac (10.0.1.24). I checked that the Firewall is off (by default) on my Mac.

smcho@macho ~> ping 10.0.1.39
PING 10.0.1.39 (10.0.1.39): 56 data bytes
Request timeout for icmp_seq 0

arp -a returns with incomplete on the Pi's local ip.

? (10.0.1.1) at MAC on en0 ifscope [ethernet]
? (10.0.1.11) at (incomplete) on en0 ifscope [ethernet]
? (10.0.1.24) at MAC on en0 ifscope permanent [ethernet]
? (10.0.1.39) at (incomplete) on en0 ifscope [ethernet]

I can use Internet from Pi (I can ping google.com from Pi), and when I execute arp -a from Pi, I get the same (incomplete) message on 10.0.1.24.

What might be wrong? I installed Raspbian with NOOBS (2015-11-21) version.

  • How does the RPi get its IP address? Is the address 10.1.0.39 or 10.0.1.39? You have both in your question. – jogco Jan 14 '16 at 7:50
  • @jogco: typo, corrected, thanks. – prosseek Jan 14 '16 at 8:02
  • Checkout this discussion on another site, particularly this post I've tested this and if I ping an unused address on my network arp -a will show it as incomplete. Is your Pi down? Check that you have good power to it. – jogco Jan 14 '16 at 8:24
  • If you use static IP for the Pi, check your setting. – jogco Jan 14 '16 at 8:33
  • 2
    Unless you describe your network architecture (what is connected to what) and list any changes you may have made to network configuration files any comment is idle speculation. arp is a waste of time - it only lists established conections. – Milliways Jan 14 '16 at 8:39

On your Raspberry Pi, run the command ifconfig.

It should give you something like this:

pi@raspberrypi ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:08:98:98  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1000 (1000.0 B)  TX bytes:1000 (1000.0 B)

wlan0     Link encap:Ethernet  HWaddr 7c:dd:90:4a:50:45  
          inet addr:192.168.0.140  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14990 errors:0 dropped:15296 overruns:0 frame:0
          TX packets:687 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2867368 (2.7 MiB)  TX bytes:73259 (71.5 KiB)

Look for a local IP address under one of the separated items and look for a local IP address with inet addr before it. This should be the local IP address of your Raspberry Pi.

Then head to your MacBook and make sure the checkbox under System Prefrences > Security > Firewall > Enable Stealth Mode is disabled. Then, via Terminal type ping <IP Address>. Where the 'IP Address' is the IP address of your Raspberry Pi.

Also, you should check that your MacBook and Raspberry Pi are both on the same network.

To save yourself actually having to go to the PI and find its ip address use nmap via the terminal on your MacBook.

This link gives an over complicated explanation but it will sort you out providing they are on the same network.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.