3

I have 2 external HDD connected to my Raspberry Pi 2. One [NTFS] (auto)mounts and flawlessly.

The other one does not mount via /etc/fstab and returns a filesystem error but mounts when I manually mount it.

manual mounting:

 pi@raspberrypi ~ $ sudo mount -t ext4 /dev/sdb1 /media/flashdrive/
 pi@raspberrypi ~ $ 

dmesg output:

[82502.877207] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)

mounting from /etc/fstab:

 pi@raspberrypi ~ $ mount /media/flashdrive/
 mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
        missing codepage or helper program, or other error
        In some cases useful info is found in syslog - try
        dmesg | tail  or so

dmesg output:

 [82436.724478] EXT4-fs (sdb1): Unrecognized mount option "uid=1000" or missing value

/etc/fstab:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults          0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, so no using swapon|off from here on, use  dphys-swapfile swap[on|off]  for that
UUID=f31eb8dc-cfca-4e23-8e85-070256e3d9c9 /media/flashdrive   ext4  auto,users,rw,uid=pi,gid=pi   0  0
UUID=CEB0EF1CB0EF09B3           /media/toshiba  ntfs   auto,users,rw,uid=pi,gid=pi    0   0

Any ideas where the issue is? (UUID is correct)

As you can see in the /etc/fstab uid=pi is identical for both drives. Still mounting only works for one of them.

  • Did you you look at dmesg | tail? – goldilocks Jan 16 '16 at 16:51
  • I updated the question with the dmesg output. dmesg says there is an issue with the uid=pi but that option is identical to both drives. Actually all options are identical except for the fs-type. – cataclysmic Jan 17 '16 at 13:59
2

If you look in man mount (which is lengthy), you will notice that different kinds of filesystems have different options available to them. These are all explained under FILESYSTEM-SPECIFIC MOUNT OPTIONS.

For example, under "Mount options for ntfs" you will find uid= and gid=; if these are not set "by default, the files are owned by root".

This is not true for ext4. Ownership and permissions are as is, and if you look under "Mount options for ext4" you will not find those two options.

The reason for this is that NTFS does not use a permissions system that is natively transferable, so file ownership must be set arbitrarily when the fs is mounted.

Hence a line that works for the NTFS drive will not necessarily work for an ext4 one.

  • Thank you for the clarification. Always thought the mount action itself was generally root specific and uid, gid only handled the filesystem access. Thank you. PS: Not allowed to upvote, yet. ;-) – cataclysmic Jan 17 '16 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.