4

sudo apt-get install fim results in the error message "unable to locate package fim". fbi seems to be fine though. Any idea why?

2

It appears that fim simply isn't in the Jessie repository. If you like, you can install it manually using the following steps.

  1. Download the source code from its project webpage.

  2. Install some dependencies: sudo apt-get install -y flex bision libreadline-dev libexif-dev libpng-dev libjpeg-dev libgif-dev libtiff-dev libpoppler-dev These were the libraries I was missing. I already have a lot of development libraries installed, so you may be missing more than this. Feel free to leave a comment if you get an error from this step.

  3. Extract the source tar xfa fim-0.5-trunk.tar.gz

  4. Enter the new directory cd fim-0.5-trunk

  5. Configure the software by running ./configure

  6. When that's finished, compile the software by running: make. Do not use the -j option. The Makefile does not appear to be properly configured for it. Note: this will take a long time to run, especially if you're not using an RPi 2. Grab a cup of coffee or something and be patient.

  7. Install the software by running: sudo make install

  8. Refresh your session. If you're using the default bash shell, this is accomplished by typing source ~/.bashrc

  9. Enjoy your new software. At this point you can delete the directory you extracted the source files to; you no longer need it.

| improve this answer | |
  • 1
    fbi (Frame buffer viewer) is a current package fbi 2.10-2+b1_armhf.deb and is dated 2015-12-19 at the time of writing. However fim is old fim_0.3-beta-prerelease-1.3_armhf.deb (Scriptable frame buffer and ascii art image viewer) dated 2012-05-10, it is NOT in the Jessie Debian distribution but only in the Wheezy one - as Raspbian is derived from Debian it is not surprising that that package is not available. – SlySven Jan 18 '16 at 12:05
1

Actually there is a new Fim build dated 2016/01/31. Compile istructions follow. Successfully built on a Raspbian Jessie as root user.

apt-get install -y flex bison libreadline-dev libexif-dev libpng-dev libjpeg-dev libgif-dev libtiff-dev libpoppler-dev checkinstall #maybe others on your system.

wget http://download.savannah.nongnu.org/releases/fbi-improved/fim-0.5-rc1.tar.gz
tar -xf fim-0.5-rc1.tar.gz 
cd fim-0.5-rc1 

./configure --disable-readline 
mkdir -p /usr/local/share/doc # Fim will fail creating by itself.
checkinstall

Change the Version field in the Checkinstall values page into a numeric one, otherwise it will fail compiling (Checkinstall issue).

Previous commands will compile Fim with framebuffer (built-in) support only and directly create a standard .deb package.

You should add the "non-dev" version of the dev- installed packages as dependencies in the Checkinstall Requires field in order for the .deb to be correctly installed on another Raspbian Jessie.

Notes.

--enable-exiftool flag seems not to work with this upstream release.

Use ./configure --help=short for a complete list of configure options specific to Fim.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.