3

I got a used Raspberry Pi Model B 1GB Version. I am noticing something weird, even without a SD Card connected to it, after powering it on and connecting HDMI I see the rainbow splash screen. Both red and green LEDs glow solid and green never flashes. What could it indicate?

  • I also used to get rainbow on "some" of my Pi's with no SD card. Its just a "test" screen that usually means the boot loader cant start... indicating it cant read the SD card or there is no SD card. Sometimes the rainbow screen shows and the Pi will boot but be unstable, I found this to be a power issue too. – Piotr Kula Jan 17 '16 at 22:44
  • The rainbow screen is provided by the GPU hardware which is initialised to produce a four pixel (2x2) image scaled to fill the screen - it does this as a result of the on-board firmware which then goes hunting for an SD card to read - leaving the Green LED on solidly. (A 1GB RPi model B will be the Raspberry Pi 2 Model B, which definitely does this - I'm not sure about the earlier ones). – SlySven Jan 18 '16 at 12:15
2

I got a used Raspberry Pi Model B 1GB Version.

I think you mean a quad core Pi 2, sometimes referred to as the "Pi 2 model B" or just "2 B" (or twobee).

Both Red and Green LED's glow solid and green never flashes. What could it indicate?

It indicates there is no card in the SD card reader. The source Jacobm001 refers to actually predates the 2.1 The BCM2835 models, including the B+, will start up with only the red light on in this case. The BCM2836 model (i.e., the 2 B) will start up with both lights on steady.

It is a little odd you get an HDMI signal, but if the Pi otherwise seems to work, nothing is broken.


1. Except for a brief note just added by me. I've observed this with the 2 as have various other people here over the past year.

  • Huh, I didn't realize that my source was out of date... I'll make an edit to mine. – Jacobm001 Jan 18 '16 at 0:19
2

According to the troubleshooting guide, it sounds like there is something wrong with the SD card reader. My guess is the SD reader is broken in some fashion if a working card is not read properly.

Edit:

Apparently my source predates the RPi 2, and may not be accurate for the newer devices. I will leave the answer, however, for anyone having the same problem with the A, A+, B, or B+ models.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.