I'd like to access the default running (vs virtual) X desktop session (the one that is visible over HDMI) over VNC - basically to use my laptop as kbd+mouse while enjoying the big TV screen connected to my Pi. I don't want to invest in extra kbd+mouse for Pi, when several network-connected laptops are available.

All those tutorials for installing and setting up tightvnc seem to be designed for those who want truly headless setup. And I don't see how I can run the tightvnc server in order to access to the active real X session.

1 Answer 1


Your most likely using TightVNC and it's behaviour does not allow access to the real (to my knowledge) x desktop session.

What your looking for is x11vnc. This allows VNC access to the default X session.

Not exactly sure what Distro you are running, but first try installing it apt-get install x11vnc. If that does not work, then you will have to download the source and compile it on the Raspberry Pi.

Just a side note: You cannot "see" any output that comes from the GPU IE: Video, games. That output is only sent over the HDMI cable for now (This will be changed sometime in the future)

UPDATE VNC GPU OUTPUT: VNC on the new Raspbian has an experimental direct capture mode. Note that the documentation says that you need to enable this setting, however my recent install of Raspbian had the setting enabled by default.

On your Raspberry Pi, open the VNC Server dialog(top right of screen) -> Navigate to Menu > Options > Troubleshooting and select Enable experimental direct capture mode.

  • Is it still the same? I want to run Genymotion on my TightVNC server remotely. how could I provide this? Commented Aug 22, 2017 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.