2

I have setup 3 raspberry pis as wifi access point using Realtek RTL8188CUS wifi dongles, and it worked like a charm. I'm following the adafruit tutorial mostly (https://learn.adafruit.com/downloads/pdf/setting-up-a-raspberry-pi-as-a-wifi-access-point.pdf). This was in november & december 2015.

yesterday I tried the exact same process (3 times), exact same hardware, same configuration and I get this error:

nl80211: Driver does not support authentication/association or connect commands

What could be the problem. Could it be a compatibility problem with the new version of Raspbian jessie? Any idea of what I could do to solve this?

1

I found my problem. I needed to update hostapd.

After trying out several ones, the one that worked was the adafruit one. http://adafruit-download.s3.amazonaws.com/adafruit_hostapd_14128.zip

It had worked without when I setup the AP in november, but not this time.

Still interested in understanding why..

0

I had the same problem with Edimax EW-7811Un USB dongle.

I was powering Raspberry Pi from my Macbook Pro. Turns out USB port on the left side of Macbook might not give enough power. When I switched to USB port on the right side of Macbook everything magically worked again.

  • keep in mind that you need good amount of current to power the Pi 2 and a WiFi Adapter. So in the future use a stand-alone power cable with a minimum 2 Ampere current rating. – Shan-Desai Mar 4 '16 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.