I have a BMP183 (from Adafruit) and I'm trying to make it work on my Raspberry Pi 2B, but I'm getting the following error:

BMP183 returned ',#randomnumber#, ' instead of 0x55. Communication failed, expect problems

I've tried this code BMP183 both master and threaded. I tried to modify the PIN in the code in the def __init__(self) function and I still get the same error.

Board and connection:

  • CS on CE0 (pin 24), red cable;
  • SDI on MOSI (pin 19), orange cable;
  • SDO on MISO (pin 21), yellow cable;
  • SCK in SCLK (pin 23), green cable;

Is there anything that I did wrong?

  • Looks okay. Does the DHT11 work okay?
    – joan
    Jan 18, 2016 at 13:19
  • Yes, DHT11 and a SRD-05vdc-sl-c dual channel relay works fine too. I haven't solder the BMP183 with the pins as in this link learn.adafruit.com/… ... should it be a contact problem?
    – Possa
    Jan 18, 2016 at 13:31

1 Answer 1


The code on GitHub you reference doesn't use the SPI interface. You could try using the same pins as shown there.

CS -> 16
SDI -> 12
SDO -> 10
SCK -> 8

Alternatively, you could use the Adafruit BMP Python library which does support SPI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.