3

So, the only place to buy raspberry pi addons where I live is an aftermarket which is not very well documented. I recently purchased a 3.5 inch resistive tft screen, with no information about the manufacturer, for about $25. I'm trying to hook it up to my Pi 2 which is running a fresh install of Raspbian Jesse, using this tutorial and a few blog posts. The problem is that I don't know the name of the device or the manufacturer, so I cannot complete the tutorial.

Here are some pics of the screen. It uses GPIO headers to connect to the pi2, but gets stuck at the white screen.


The Steps I have followed so far:

  • Installed a fresh copy of Raspbian Jesse (from raspberry pi website) on my Raspberry Pi 2.
  • Expanded my filesystem to the full SD card (I had some problems with the later steps the first few times I tried this)
  • Performed sudo apt-get update and sudo apt-get upgrade (in that order)
  • Performed sudo rpi-update
  • Rebooted
  • Edited the file: sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf , changed “fbdev” “/dev/fb0” to “fbdev” “/dev/fb1”
  • Since my Raspbian was after 1-31-2015, I entered sudo raspi-config and enabled SPI automatic loading and kernel.
  • Rebooted
  • Downloaded the notro files with sudo REPO_URI=https://github.com/notro/rpi-firmware rpi-update[EDIT: I did this process again but by using sudo rpi-update instead, no dice]
  • Rebooted
  • Edited file: sudo nano /etc/modules to:

smd-bcm2836

spi-bcm2708

fbtft_device name=waveshare32b gpios=dc:22,reset:27 speed=48000000

waveshare32b width=320 height=240 buswidth=8 init=-1,0xCB,0x39,0x2C,0x00,0x34,0x02,-1,0xCF,0x00,0XC1,0X30,-1,0xE8,0x85,0x00,0x78,-1,0xEA,0x00,0x00,-1,0xED,0x64,0x03,0X12,0X81,-1,0xF7,0x20,-1,0xC0,0x23,-1,0xC1,0x10,-1,0xC5,0x3e,0x28,-1,0xC7,0x86,-1,0x36,0x28,-1,0x3A,0x55,-1,0xB1,0x00,0x18,-1,0xB6,0x08,0x82,0x27,-1,0xF2,0x00,-1,0x26,0x01,-1,0xE0,0x0F,0x31,0x2B,0x0C,0x0E,0x08,0x4E,0xF1,0x37,0x07,0x10,0x03,0x0E,0x09,0x00,-1,0XE1,0x00,0x0E,0x14,0x03,0x11,0x07,0x31,0xC1,0x48,0x08,0x0F,0x0C,0x31,0x36,0x0F,-1,0x11,-2,120,-1,0x29,-1,0x2c,-3

ads7846_device model=7846 cs=1 gpio_pendown=17 speed=1000000 keep_vref_on=1 swap_xy=0 pressure_max=255 x_plate_ohms=60 x_min=200 x_max=3900 y_min=200 y_max=3900

  • Edit /boot/cmdline.txt to:

dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait fbtft_device.custom fbtft_device.name=waveshare32b fbtft_device.gpios=dc:22,reset:27 fbtft_device.bgr=1 fbtft_device.speed=48000000 fbcon=map:10 fbcon=font:ProFont6x11 logo.nologo dma.dmachans=0x7f35 console=tty1 consoleblank=0 fbtft_device.fps=50 fbtft_device.rotate=0

  • Added to sudo nano /etc/rc.local :

su -l pi -c startx

  • sudo raspi-config and enabled loading into desktop GUI autologin by default.
  • 48 million bits per second SPI rate seems ambitious to me. I'd try something like 1000000 (1 million) while you are testing. All you can do is 1) try the settings for various TFT and hope for the best, or 2) google for similar images and try to track it down that way, or 3) post the images (particularly the back view) on as many sites as possible and hope someone else has one. – joan Jan 23 '16 at 9:15
  • Did you check the seller's page? – Gene Jan 23 '16 at 11:09
  • The seller has no online page, they only own a brick-and-mortar store (albeit a reputable one) which is where I bought it. I tried contacting them, but they aren't really responding. – Abhishek Divekar Jan 23 '16 at 11:35
  • As I was looking for you problem I found similar LCD on github discussion. Look if this page: link helps you. – Bungee75 Jan 23 '16 at 11:46
  • Actually, I figured it out :D I emailed the manufacturer and they were kind enough to respnod with a link to the drivers: spotpear.com/learn/EN/raspberry-pi/Raspberry-Pi-LCD/… – Abhishek Divekar Jan 23 '16 at 12:28
2

Well, so I contacted the seller and they were kind enough to email me the link to the product: http://www.banggood.com/3_5-Inch-320-X-480-TFT-LCD-Display-Touch-Board-For-Raspberry-Pi-BB-p-958458.html

Then, I was redirected to this page (http://www.spotpear.com/learn/EN/raspberry-pi/Raspberry-Pi-LCD/Drive-the-LCD.html), which had everything I needed to install it. It works absolutely fine now on Rapsbian Jesse, trying on Ubuntu Mate with BerryBoot.

EDIT:

So, I looked inside the .tar.gz archive. I think my device was a waveshare35a after all! And the only reason it wasn't working with the tutorial I mentioned is because I didn't try it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.