After performing sudo apt-get update && sudo apt-get upgrade, I got the message

The following packages have been kept back:

What I usually do in this case, is sudo apt-get install mopidy. This resulted in the following message:

The following packages have unmet dependencies:
   mopidy : Depends: python:any (< 2.8) but it is not installable
            Depends: python:any (>= 2.7.5-5~) but it is not installable

Is there some way to upgrade mopidy? I've checked, but Python is already at the latest version...

  • 1
    What is the output of python -V? <- Beware capital V.
    – goldilocks
    Commented Jan 23, 2016 at 13:26
  • 1
    @goldilocks: Python 2.7.3
    – Martijn
    Commented Jan 23, 2016 at 13:38
  • 1
    @goldilocks, docs.mopidy.com/en/latest/installation/debian claims that mopidy comes in packages for wheezy and jessie. But does the above errors not suggest something from with dependencies - python (for whatever reason)?
    – Ghanima
    Commented Jan 23, 2016 at 13:49
  • 1
    @goldilocks: that explains it. I've still got wheezy, which has python 2.3.7, but mopidy's package (for wheezy) requires python 2.7. I'll drop them a line, and will attempt to get my pi on jessie tomorrow. Thanks!
    – Martijn
    Commented Jan 23, 2016 at 14:18
  • 1
    @SlySven: ack! You're right, I forgot the crucial .5 there, sorry.
    – Martijn
    Commented Jan 24, 2016 at 6:08

1 Answer 1


I'm one of the Mopidy core developers and the one packaging Mopidy for Debian.

It looks like you're trying to install the Mopidy Debian package as built for Debian jessie (stable) on a wheezy system (oldstable).

Please visit https://docs.mopidy.com/en/latest/installation/debian/ and follow the instructions for wheezy. You'll then get packages built on and for wheezy, which works with the Python 2.7 version you already have.

  • That's odd, I haven't done anything at all (yet) in order to get jessie (I wasn't even aware that it was available till I read @goldilocks' comment on this question. cat /etc/issue gives ‛Raspbian GNU/Linux 7 \n \l‛.
    – Martijn
    Commented Jan 23, 2016 at 20:39
  • Thanks, it works. Apparently I was still using raspbian's packages for mopidy, not mopidy's own.
    – Martijn
    Commented Jan 23, 2016 at 21:03
  • If you already used Raspbian's packages for Mopidy they should match the Raspbian version you have. If you used Mopidy's own packages (which are really the same, but newer) you probably had "stable" as the dist in /etc/sources.list.d/mopidy.list. With the release of jessie last April the meaning of "stable" changed from wheezy to jessie, and you started getting the wrong set of packages.
    – jodal
    Commented Jan 24, 2016 at 5:34
  • That's the puzzling thing, AFAIR I was using Raspbian's packages for Mopidy. I run apt-get update && apt-get upgrade at least once a month, and suddenly it gave me this error message.
    – Martijn
    Commented Jan 24, 2016 at 15:45
  • Mopidy doesn't exist in Raspbian wheezy and hasn't had any upgrades in Raspbian jessie since jessie was released in April 2015. However, I uploaded a Debian package of Mopidy 1.1.2 to apt.mopidy.com a few days ago. Sounds like you already used apt.mopidy.com :-)
    – jodal
    Commented Jan 24, 2016 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.