2

I have a raspberry pi 2 model B version 1 running raspbian that I am trying to get a Wii remote to work with. I have an Inateck Bluetooth 4.0 adapter plugged in to it and have CWiiD installed. When I type hcitool scan and push 1 + 2 on Wii remote the output is

Scanning ...
    58:BD:A3:C4:9E:7C   Nintendo RVL-CNT-01-TR

However, when I go to python 2.7.9 and run this code it always outputs

Press 1 + 2 on your Wii Remote now ...
No wiimotes found
Error opening wiimote connection

(The "No wiimotes found" only show up when I run the code with sudo python wii_remote_1.py instead of just python wii_remote_1.py)

Please tell me if you know how to fix this.

6
  • What OS (Raspian etc. are you using) - that CWiiD package comes from the Ubuntu site, so perhaps you mean the packages here. The message about "No Wiimotes found" means that the library is operable (the failure unless using sudo means there is a permissions problem with the normal user that you are, "pi" perhaps, with the device that represents the hardware concerned. Given this is a Bluetooth device I wonder whether the RPis Bluetooth system is not (yet) paired with the Wiimote device...
    – SlySven
    Jan 24 '16 at 6:22
  • CWiiD has been rumored to only work with the Nintendo brand Wiimotes, make sure you don't have a knock off one. Jan 24 '16 at 8:01
  • Right now I am using raspbian and I am using a wii remote that has the nintendo and wii logo, so I assume is the official remote.
    – XMB5
    Jan 24 '16 at 13:37
  • I have 2 knock off ones - I ended up using the 2 that came with the Wii
    – XMB5
    Feb 12 '18 at 22:43
  • New wiimote batteries fixed it for me! Apr 23 '19 at 8:41
0

I fixed the problem. Heres what I did. I do not know what actually made it work, but it is working.

  1. Used different Wii remote
  2. Turned off Wii
  3. Re-Installed Raspbian (Saved all important files on usb so they wouldn' be erased)
  4. Downloaded and installed bluetooth and cwiid

I think that the Wii remote was trying to connect with the Wii and messing up the raspberry pi, but I don't know for sure.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Feb 22 '20 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.