2

I installed Rasbian Jessie Lite on my Raspberry Pi Zero a few hours ago.

I hooked up a multi-usb hub to the Zero. The hub has an ethernet port, where I connected my modem.

I ran apt-get install for:

  • xorg

  • mate-desktop-environment-core

  • wicd (internet network manager I like)

  • epiphany-browser

I could browse the internet just fine for a while, but now I can't connect. wget http://google.com tells me the host could not be resolved.

When I open Wicd while connected straight to my modem, I see the wired network as an option. I click "Connect," everything seems to run, but the Zero just does not connect.

Here's my output from wicd.log on my most recent connection attempt:

  2016/01/23 19:54:34 :: Sending connection attempt result failed

  2016/01/23 19:54:34 :: Putting interface down

  2016/01/23 19:54:34 :: Releasing DHCP leases...

  2016/01/23 19:54:34 :: Setting false IP...

  2016/01/23 19:54:35 :: Stopping wpa_supplicant

  2016/01/23 19:54:35 :: Flushing the routing table...

  2016/01/23 19:54:35 :: Putting interface up...

  2016/01/23 19:54:37 :: Running DHCP with hostname raspberrypi

  2016/01/23 19:54:37 :: dhcpcd[4285]: sending commands to master dhcpcd process

  2016/01/23 19:54:37 :: 

  2016/01/23 19:54:37 :: 

  2016/01/23 19:54:37 :: DHCP connection successful

  2016/01/23 19:54:38 :: Connecting thread exiting.

  2016/01/23 19:54:38 :: Sending connection attempt result success
3

I bet your DNS resolvers aren't configured. This is a common issue in Linux.

Add nameservers in the /etc/resolv.conf file by adding the lines below:

nameserver 208.67.222.222
nameserver 8.8.8.8

These lines add OpenDNS' nameserver (first line) and Google's DNS server (2nd line)

Alternatively, you could add the DNS servers in the GUI network manager by clicking "Properties" under the connection then setting Static DNS to the IP addresses provided.

  • 1
    Added those lines, rebooted, but still no luck – Username Jan 24 '16 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.