0

Pi picks up a strong wi-fi signal but I can't access the internet. I get the "Oops!" message. I have used the wi-fi password on the back of the modem for the Pre Shared Key.

2
  • 6
    Can you be a bit more detailed - I, for one, have no idea what the "Oops!" message is - though I can guess it is something telling you that something has gone wrong. So: what OS+version (Raspian "Jessie" perhaps?), what WiFi adapter (have the right drivers been installed) - have you set-up your RPi correctly - and used the right password (using the defaults on your modem is usually not best policy as for some models the defaults can be guessed/looked up) also, is that the right password, not the one you need to use to "get into" your modem/route to change settings, but the Wifi WPA(2) key?
    – SlySven
    Jan 24 '16 at 17:41
  • Is it successfully connected to the router? Or is that the part that errors?
    – Jacobm001
    Jan 25 '16 at 15:36
2

You should first try to ping the internet like ping stackoverflow.com. If you get a Connection timeout or an unknown host, then you should check your DNS settings.

If you can ping to 8.8.8.8 then it's probably a DNS issue.

You also could connect your USB WIFI adapter to a powered USB hub. Some USB devices are not working properly because the PI could not provide sufficient power.

Some USB WIFI adapters have driver/power issues like the Equip WIFI N adapter I had. My Equip WIFI N adapter had a 100% signal but a speed of 20KB/s and an unstable connection.

0
0

I have stumbled upon a problem with wi-fi devices that might be of help. If your password is very long (as default wi-fi modem passwords are) you might have to change it to a shorter password. This did the trick for my and my Pi with a wn725n adapter and my HP laser printer.

I suggest you connect to your router with an ethernet cable (or other computer able to log into it), enter the admin pages (you will be asked for a login and a password: they usually are "admin" "admin", "admin" "root", or "root" "root") and navigate to the wi-fi settings. There you can change your wi-fi wpa password to a shorter one. Remember to change the wi-fi password on all other devices afterwards, otherwise you'll end up with the Pi connecting and all other pcs disconnected.

If this does not fix it, please do the effort to add some more detail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.