1

I installed Ubuntu 14.04.02 LTS on my Raspberry pi 2 model B.

My Raspberry pi 2 is connected to my home router with LAN cable and monitor with HDMI cable.

When Raspberry pi is on, the monitor displays,
Monitor

Since I don't have a usb keyboard, I am unable to type directly in my Raspberry PI.

So this is what I did :

I find my Raspberry's IP address(192.168.7.167) on my router's admin page.

When I sent ping to this IP address from my Macbook, it responds pretty well.

So, I tried to access my Raspberry pi using ssh on my Macbook,

ssh ubuntu@192.168.7.167

But there is an error,

ssh: connect to host 192.168.7.167 port 22: Connection refused

I have no idea why I can't access using ssh.

Please give me some advice on this matter. Thanks

3

It seems that your SSH server is not running. Normally, you would type:

sudo raspi-config

to configure and run SSH server. However, without USB keyboard, you might only mount SD card and via chroot, execute aforementioned command. You might also try to find RPi image with SSH server running by default.

It might be also helpful to take a look on this post: Enabling SSH on RPi without screen - keystrokes for raspi-config?

| improve this answer | |
-2

Try to use https://www.virtualbox.org/ an enable ssh. I don't know if it works.

| improve this answer | |
  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Ghanima Apr 7 '16 at 16:56
  • It is also preferable to post answers that you know work. If you could test your suggestion first, that would be most helpful. – Greenonline Apr 8 '16 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.