I am following a tutorial that is based on a Chrome extension so I have to install Chrome. When I tried the following command:

sudo apt-get install chromium 

I get the following error:

E: Package 'chromium' has no installation candidate.

I understand that it could be an architecture problem but what is the solution in my case? I am using a Raspberry Pi 2 Model B.

sudo apt-get install chromium-browser
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package chromium-browser is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'chromium-browser' has no installation candidate

The same goes when trying to install chromium. Also I get this when pressing tab:

pi@raspberrypi ~ $ sudo apt-get install chro
chromium-bsu        chromium-l10n       chrootuid
chromium-bsu-data   chronicle           
chromium-inspector  chrony 

6 Answers 6


Try sudo apt-get install chromium-browser

  • not working. Can you please take a look at the updated question?
    – Mona Jalal
    Commented Jan 24, 2016 at 23:58
  • 3
    Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include some explanation here, e.g. what do these commands do? (It was automatically flagged as low quality due to its length.)
    – Ghanima
    Commented Jan 25, 2016 at 0:40
  • @aaron you might wanna add my answer to your tutorial for those who are using Jessie
    – Mona Jalal
    Commented Jan 25, 2016 at 0:44
  • 5
    As of September 2016 chromium-browser (Chromium 51) is available through the standard Jessie distribution. Commented Oct 1, 2016 at 17:46
  • As of August 2017, chromium-browser package on raspbian Stretch matches the latest available version (Chromium 60)
    – Quentin S.
    Commented Aug 26, 2017 at 16:34

For the Raspberry Pi Model 3 with Raspbian Jessie, copy and paste these 5 lines individually into the terminal:

sudo apt-get update
wget -qO - http://bintray.com/user/downloadSubjectPublicKey?username=bintray | sudo apt-key add -
echo "deb http://dl.bintray.com/kusti8/chromium-rpi jessie main" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install chromium-browser
  • 1
    This should be the "correct" answer, because it installs the latest chromium version. Commented Sep 28, 2016 at 14:12
  • used this on debian stretch, works well too. Commented Jan 13, 2018 at 18:15

Use these commands to install chromium-browser on Jessie (not Wheezy):

wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser-l10n_45.0.2454.85-0ubuntu0.
wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser_45.0.2454.85-0ubuntu0.
wget https://dl.dropboxusercontent.com/u/87113035/chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.
sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.
sudo dpkg -i chromium-browser-l10n_45.0.2454.85-0ubuntu0. chromium-browser_45.0.2454.85-0ubuntu0.

^answer is from @dfaze comment's link

  • 2
    Is there any updated version available? Commented Feb 11, 2016 at 3:21
  • 8
    I would recommend to use a more official source.
    – czerasz
    Commented Jul 22, 2016 at 20:11
  • Thanks a lot for this.. I have been trying to install chromium a lot of time without success. It's even more faster than Epiphany browser. Far more faster.
    – fabrosell
    Commented Jul 27, 2016 at 1:38
  • 1
    @fabrosell I agree for me duck duck go default browser is Jessie was so slow that I did all my best to find a way to install Chromium. It might not sound official but it works. I have done it various times and never failed.
    – Mona Jalal
    Commented Jul 27, 2016 at 4:29
  • 1
    Check @tyrell-van-den-heever answer it installs the latest version of chromium instead of the old 45 version. Commented Sep 28, 2016 at 14:13

This happens when you try to install a package APT doesn't know about. When you add software sources and run apt-get update, your system APT database is updated with all the packages on the repositories listed in the software sources list.

Then when you try to install a package, apt checks the package name in its database, finds it and checks the name of the repo from where it got it. It then downloads the package from that repo.

It is always useful to run apt-get update before doing apt-get install XXX, to ensure you get the latest software version that is on repo.

  • 1
    I did the update and upgrade before running it and still the same error!
    – Mona Jalal
    Commented Jan 24, 2016 at 22:54
  • Have you tryed apt-get install chro and then press tabkey? you'll have a list of package starting with that... my rasp find chromium, chromium-browser ... isn't it the "browser" that you need?
    – DFaze
    Commented Jan 24, 2016 at 23:04
  • 1
    first make sure that bash-completion is installed: sudo apt-get install bash-completion or maybe sudo apt-get install --reinstall bash-completion and watch in your user directory (/home/pi by default) if you find a .bashrc file. if not, copy it from cp /etc/skel/.bashrc ~/
    – DFaze
    Commented Jan 24, 2016 at 23:17
  • 1
    oh sorry...! i was testing on my Wheezy Rasp... on the Jessie one ... I have the same problem as you...! may try this link : raspberrypi.org/forums/viewtopic.php?t=121195 they show how to download the package and install it ;)
    – DFaze
    Commented Jan 25, 2016 at 0:23
  • 1
    You don't need. The link I recommend is not so old and you only have to follow directives in "code section" : wget 3 packages and dpkg (install package) them
    – DFaze
    Commented Jan 25, 2016 at 0:45

I can confirm that, as of this post, sudo apt-get install chromium-browser works on Ubuntu MATE 15.10 on the Raspberry Pi 3.

wget http://ports.ubuntu.com/pool/universe/c/chromium-browser/chromium-browser-l10n_48.0.2564.82-0ubuntu0.
wget http://ports.ubuntu.com/pool/universe/c/chromium-browser/chromium-browser_48.0.2564.82-0ubuntu0.
wget http://ports.ubuntu.com/pool/universe/c/chromium-browser/chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0.

sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0.
sudo dpkg -i chromium-browser-l10n_48.0.2564.82-0ubuntu0. chromium-browser_48.0.2564.82-0ubuntu0.

All credits go here.

Ansible version:

- hosts: all
    chromium_version: 48.0.2564.82
    # --- Install Chromium Browser ---
    - name: Download chromium packages
        url: "http://ports.ubuntu.com/pool/universe/c/chromium-browser/{{ item }}"
        dest: /home/pi/Downloads/
        owner: pi
        group: pi
        - "chromium-codecs-ffmpeg-extra_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_armhf.deb"
        - "chromium-browser_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_armhf.deb"
        - "chromium-browser-l10n_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_all.deb"

    - name: Install chromium packages
        deb: "/home/pi/Downloads/{{ item }}"
        - "chromium-codecs-ffmpeg-extra_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_armhf.deb"
        - "chromium-browser_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_armhf.deb"
        - "chromium-browser-l10n_{{ chromium_version }}-0ubuntu0.{{ ubuntu_version }}_all.deb"
    # --- END: Install Chromium Browser ---

Find a project integration here.

I would strongly encourage to add a checksum check (not present in the Ansible version as well) since the files are downloaded over http.


Not the answer you're looking for? Browse other questions tagged or ask your own question.