0

i'm having some trouble when trying to connect to my raspberry b+. i have used buildroot and add dropBear package for SSH . I gave the pi a static adress 10.42.0.5 and it's detected correctly in my ethernet network here are some commands :

nmap -sP 10.42.0.0/24
Starting Nmap 6.40 ( http://nmap.org ) at 2016-01-25 02:23 WET
Nmap scan report for 10.42.0.1
Host is up (0.00017s latency).
Nmap scan report for 10.42.0.5
Host is up (0.0069s latency).
Nmap done: 256 IP addresses (2 hosts up) scanned in 2.61 seconds

The pi adress is 10.42.0.5

For the ping it runs successfully

ping -c 3 10.42.0.5
PING 10.42.0.5 (10.42.0.5) 56(84) bytes of data.
64 bytes from 10.42.0.5: icmp_seq=1 ttl=64 time=4.83 ms
64 bytes from 10.42.0.5: icmp_seq=2 ttl=64 time=3.03 ms
64 bytes from 10.42.0.5: icmp_seq=3 ttl=64 time=2.03 ms

--- 10.42.0.5 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 2.035/3.303/4.836/1.158 ms

But whe trying ssh i get connection refused

ssh pi@10.42.0.5
ssh: connect to host 10.42.0.5 port 22: Connection refused

Note : i think this is not a duplicate since i have used BUILDROOT not raspbian or some other official distributions for raspberry

thanks

  • 2
    Did you start dropbear on the Pi? e.g. "dropbear -R" – Richard Pennington Jan 25 '16 at 2:41
  • Do you have sshd running on the pi? – Havnar Jan 25 '16 at 9:37
  • @RichardPennington i can't connect to the pi for now ! so i can't give you a response – The Beast Jan 25 '16 at 11:34
  • @Havnar i can verify that because i couldn't connect to the pi – The Beast Jan 25 '16 at 11:35
  • Connect directly with keyboard and screen and tell us. You probably miss-configured openssh. Then check the error logs, running services and configs. – Jakuje Jan 25 '16 at 17:19
1

Check netstat output on the RPI to check whether SSH server is open and listening. You can run following command and see whether dropbear is activily listening for connection

netstat -ta | grep ssh | grep -v grep

You might have enabled iptables(firewall) check whether you are not blocking the SSH port traffic (default port 22). List iptables rules to validate that

iptables -L

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.