1

I have set up a RetroPie running on a RaspBerry PI 2 with a the latest RetroPie. I have managed to mount an external harddrive and play all my games from there. I tried playing and saving the games but saving always fail which implies that I don`t have the proper permission set in my HD. I've messed around with chmod but I can only manage to write in this drive with root acess. what do i do to change the permission of this drive and make it writable for any user?

sudo findmnt gives me that

TARGET                           SOURCE    FSTYPE   OPTIONS
/                                /dev/mmcblk0p6
                                           ext4     rw,noatime,data=ordered
├─/dev                           devtmpfs  devtmpfs rw,relatime,size=372312k,nr_
│ ├─/dev/shm                     tmpfs     tmpfs    rw,nosuid,nodev
│ ├─/dev/pts                     devpts    devpts   rw,nosuid,noexec,relatime,gi
│ └─/dev/mqueue                  mqueue    mqueue   rw,relatime
├─/sys                           sysfs     sysfs    rw,nosuid,nodev,noexec,relat
│ ├─/sys/fs/cgroup               tmpfs     tmpfs    ro,nosuid,nodev,noexec,mode=
│ │ ├─/sys/fs/cgroup/systemd     cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ ├─/sys/fs/cgroup/cpuset      cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ ├─/sys/fs/cgroup/cpu,cpuacct cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ ├─/sys/fs/cgroup/blkio       cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ ├─/sys/fs/cgroup/devices     cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ ├─/sys/fs/cgroup/freezer     cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ │ └─/sys/fs/cgroup/net_cls     cgroup    cgroup   rw,nosuid,nodev,noexec,relat
│ ├─/sys/kernel/debug            debugfs   debugfs  rw,relatime
│ ├─/sys/fs/fuse/connections     fusectl   fusectl  rw,relatime
│ └─/sys/kernel/config           configfs  configfs rw,relatime
├─/proc                          proc      proc     rw,relatime
│ └─/proc/sys/fs/binfmt_misc     systemd-1 autofs   rw,relatime,fd=22,pgrp=1,tim
├─/run                           tmpfs     tmpfs    rw,nosuid,nodev,mode=755
│ ├─/run/lock                    tmpfs     tmpfs    rw,nosuid,nodev,noexec,relat
│ ├─/run/user/0                  tmpfs     tmpfs    rw,nosuid,nodev,relatime,siz
│ └─/run/user/1000               tmpfs     tmpfs    rw,nosuid,nodev,relatime,siz
├─/boot                          /dev/mmcblk0p5
                                           vfat     rw,relatime,fmask=0022,dmask
└─/media/usb0                    /dev/sda5 vfat     rw,nodev,noexec,noatime,nodi

the last entry shows my HD mounted

If I edit /etc/fstab I get the following entry:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p5  /boot           vfat    defaults          0       2
/dev/mmcblk0p6  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
1

Run sudo findmnt (with the drive mounted) and paste the output into your question (at least the relevant part).

You can ensure the drive is mounted by editing /etc/fstab. To specify the settings you need to tell us more about the drive.

You are mounting a FAT partition so there are few options. (see https://raspberrypi.stackexchange.com/a/41233/8697 for more explanation.

  1. Make a directory to mount in. I suggest /mnt/MYDISK but you can use any name.
  2. Change permissions so everyone has access e.g. chmod 755 /mnt/MYDISK
  3. Add a line like the following to /etc/fstab

    /dev/sda5 /mnt/MYDISK vfat defaults,noatime,noauto 0 0

(You can change the noauto to auto if you want it automatically mounted)

0

I have managed to make it work by editting /etc/usbmount/usbmount.conf and add FS_MOUNTOPTIONS="-fstype=vfat,umask=0000" .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.