I have a problem with my Raspberry Pi 2, after a week yesterday I tried to boot up but it won't read my SD Card & I'm not getting any display on my TV. I checked the PWR & ACT led on the board they both were solid and as much as I know the ACT led should be blinking, which tells us whether raspi is able to read SD card or not. I also tried switching my SD cards. Previously it used to show rainbow colours on the screen when I booted it up without SD Card or with SD Card. I'm running NOOBs v1.5 on my SD Cards and I'm using Samsung MicroSDHC Class 6 SD Card. I've got 2 of them.

  • "the PWR & ACT led on the board they both were solid" -> Most likely indicating the card is not formatted correctly. Did you buy the cards with the image installed, or did you do it yourself?
    – goldilocks
    Commented Jan 26, 2016 at 14:56
  • You should edit that information (a link to "the website") and exactly what you did into the question. Use the edit button, do not put it in comments.
    – goldilocks
    Commented Jan 26, 2016 at 15:13
  • No, I formatted it by following instructions on (elinux.org/RPi_Easy_SD_Card_Setup)
    – Hardik
    Commented Jan 26, 2016 at 15:20
  • Is the light flashing on raspberry Pi? Commented Jul 27, 2016 at 4:30

4 Answers 4


try this:

  • since led are solid ( not off and not blinking ), it is not a power issue.
  • Check the content of SD on a PC. Is SD OK ? readable ? conataining files ?
  • wheather you are using RGB or HDMI my suggestion is to move to pc display ( just to be on the safe side fo diagnosing ).
  • Try with and without SD inside slot ( when there is a SD inside you sould see that "rainbow" screen ). Does RPi reacts to SD inside ?
  • If there is "rainbow" screen, try boot again, holding SHIFT key. If you get a slection screen it means: A) your RPi is functioning OK, B) NOOBs is running OK until this part.

Update for further assistance,


  • Didn't work I think there's problem with the SD Card reader on RPI.
    – Hardik
    Commented Mar 26, 2018 at 8:49

You shoud try to test your hdmi cable on some other devices. (You can even try an other hdmi cable with your pi) If cable works correctly on some other device you can use google to find tutorial how to set up rasperry pi sd card correctly. But if it still does not work i thik you shoud contact rasperry pi directly or the retailer where you bought it. I personaly have had broplems with my raspi and hdmi cables.

  • I tried to change the HDMI cable & TV also, but no success!
    – Hardik
    Commented Jan 27, 2016 at 1:30
  • You should try to make the sd card for rasperry pi using this guide.
    – Jussi Roos
    Commented Jan 27, 2016 at 13:32
  • I followed the guide but no success.
    – Hardik
    Commented Jan 27, 2016 at 13:36
  • Did you download new noobs image or did you use the same one as earlier? Because it can be damged.
    – Jussi Roos
    Commented Jan 27, 2016 at 13:38
  • I downloaded latest noobs image.
    – Hardik
    Commented Jan 27, 2016 at 16:04
  1. SD card needs to be formatted as FAT32

  2. Use Etcher if you aren't already doing so.

  3. Download Raspbian Desktop ZIP file from Raspberry Pi Foundations Download website

  4. Don't open ZIP file. Burn to SD card with etcher.

  5. Make sure you are using a correct power supply. RPi2: 2 Amps, 5 volts. RPi3: 2.5 Amps, 5 volts.

  6. Plug HDMI, Keyboard and mouse into RPi.

  7. Turn on monitor and boot RPi.

  8. Setup.

  9. Want to use NOOBS? Tell me in comments.


This may happen due the corruption of memory card plz download SDcard formatter and format your memorycard and WRITE the rasbian software using windisk imager (latest release is STRETCH).plz check the memory of your card in my computer if it is showing some 64mb out of 4/8/16 GB then partition your memory card (youtube videos are available for partitioning)

  • 1
    Please edit your answer to use proper spelling and grammar. Links to the tools and videos you mention would also improve your answer. Commented Nov 12, 2017 at 6:06
  • Iwould suggest some checkings before going that way...
    – guyd
    Commented Nov 12, 2017 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.