6

I've bought a month ago a new Raspberry Zero to try this little toy. I'm already playing with a Raspberry and linux OS in general but this time i'm very close to give up. The problem is that this Raspy won't display boot messages, this is what i've tried:

  • 16gb with NOOBS v1.5.0 image (boots on pi2)
  • Same 16gb card with raspian jessie image (2015-11-21 and also this boots on pi2)
  • Old 8gb SD from pi2 with jessie raspian ( this give 7 green led flashes )
  • .txt file to force HDMI hotswap and other commands video-related (copied below)
  • HDMI to DVI cable
  • HDMI to HDMI cable (actually I've tried 2 of them)
  • Different monitor or TV
  • With or without micro USB to female Usb adapter to connect a keyboard

here is my config.txt:

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
config_hdmi_boost=4
overscan_left=24
overscan_right=24
overscan_top=16
overscan_bottom=16
disable_overscan=0

In general I can see the green led acting as a status led when is loading but no HDMI output is showing on monitor.

I hope to have been detailed as possible, unfortunately with mi first RPi B and the RPi 2 i've never issued this kind of problem.

Here is the video of the problem, for the full time the monitor still black with no signal alert: Video link

Thanks in advance!

UPDATE 1

I tried to connect the UART to my USB to ttl converter during boot and now I can see all mesages and login prompt. Seems working ok but still no HDMI output. I alredy tried to tweak the output with all available mode on tvservice command but both my monitor and my tv shows no signal.

  • 2
    By "txt file to force HDMI hotswap" you mean adding hdmi_force_hotplug=1 to config.txt? Have you tried hdmi_safe=1 (see here). Beware that if you seriously want help, you should make a serious effort to detail exactly what you've done, exactly what's happened, etc. – goldilocks Jan 26 '16 at 20:05
  • 3
    ...Otherwise questions of the sort "I've tried everything, please someone tell me something else" are likely to be ignored as tiresome -- one reason being that no one wants to spend time suggesting XYZ only to hear "Oh yeah I tried that already, anything else, please, again?" – goldilocks Jan 26 '16 at 20:05
  • I have had no issues with running Raspbian on the Pi Zero (I have several of them) straight out of the box, displaying perfectly fine on an HDMI monitor. All you need is a mini-HDMI to HDMI adapter. I do not know why you needed to change the config.txt file to tinker with HDMI. – Phil B. Jan 26 '16 at 20:13
  • @PhilB. I think this may vary somewhat depending on the display (not all HDMI implementations are equal). – goldilocks Jan 26 '16 at 20:20
  • 1
    Maybe - I actually use monitors with DVI in, so my HDMI cable is an HDMI -> DVI cable. But I never have had any issues, neither with all my different types of fullsize RPis, nor with the Zero. Anyways, it would be much easier to answer if the OP added more details about the problem he is facing, including details on the changes he made and why he made them ... then we can take this out of the guessing realm and start properly answering the question :) – Phil B. Jan 26 '16 at 20:22
2

I swapped the HDMI connector for an actual cable and it worked. Guess these adapters are not all equal

Not the answer you're looking for? Browse other questions tagged or ask your own question.