7

I am attempting to setup a Plantronics .Audio 400 DSP with a Raspberry Pi 2 Model B as the default device with Jessie installed. Headset Link: http://www.plantronics.com/us/product/audio-400-dsp

So far in all attempts I have been unsuccessful in setting this up as the default device. The USB is recognized by the Pi, and manually selecting this via aplay or arecord work:

aplay test.wav –Dsysdefault:CARD=DSP
arecord test.wav –Dsysdefault:CARD=DSP

Below I will include some research I have done and what I attempted:

In short, does anyone have detailed instructions on how to connect a USB Headset (microphone + headphones) to a Raspberry Pi 2 with Jessie installed as the default device?

Thanks!

  • Been trying to do the same thing with the same headphones. The program PulseAudio Volume Control helps to set various options for input and output of sound devices. But I have yet to get the microphone to work on the headset. Sorry this isn't too helpful. – energyi Feb 5 '16 at 23:52
  • 1
    Try this? superuser.com/a/1045885/20881 – Leif Gruenwoldt Feb 26 '16 at 18:21
0

From your first link, change default cards to 1, and also un-comment the line that says, load card-specific configuration files (on request). Then go into and edit /lib/modprobe.d/aliases.conf and change the line, options snd-usb-audio index=-2, to, options snd-usb-audio index=0, then run, cat /proc/asound/cards, and check to see that your device is at 0.

References: - https://superuser.com/questions/989385/alsa-base-conf-missing-in-new-raspberry-pi-raspbian-jesse - http://cmusphinx.sourceforge.net/wiki/raspberrypi

0

Have you been trying to create and use an ~/.asoundrc file? I have not been using USB-speakers or microphones yet but set my Bluetooth speakers and microphones as system-defaults via this file.

Create the file ~/.asoundrc with the following content:

pcm.!default {
    type hw
    card 1
}

ctl.!default {
    type hw
    card 1
}

Explanation: USB sound cards are registered as card 1 on Raspbian Jessie. (see: Best way to setup USB mic as system default on Raspbian Jessie)

If this does not help I provide you my working bluetooth-config, maybe you are able to translate it according to your USB-device-properties:

pcm.!default {
        type plug
        slave {
                pcm {
                        type bluealsa
                        device <MAC>
                        profile "a2dp"
                }
        }
        hint {
                show on
                description "Calisto"
        }
}
ctl.!default {
        type bluealsa
}

EDIT: It seems that you also have to edit your alsa-base.conf file. Have look at: Unable to set default input and output audio device on Raspberry jessie

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.