4

The seafile-client from https://www.seafile.com/en/download/ it not working, because it is not compiled for arm.

How can I install seafile-client for raspberry pi?

6

Here is a Guide how to compile seafile-client on Raspbian Wheezy:

1) Install all dependencies available in the repository:

sudo apt-get install qt4 doxygen cmake sqlite3 libsqlite3-dev openssl libssl-dev libevent-2.0-5 libevent-dev python-pip libjansson-dev automake libtool libglib2.0-dev uuid-dev valac libfuse-dev libcurl4-gnutls-dev 
#wait very long time

2) build dependency libsearpc:

git clone https://github.com/haiwen/libsearpc
#just to get the the same version I used (optional)
git checkout 8998e7b2c5587f0b94c48db24e2952d08def5add 
cd libsearpc
./autogen.sh 
./configure
make
sudo make install
cd ..

3) build dependency ccnet:

git clone https://github.com/haiwen/ccnet.git
#just to get the the same version I used (optional)
git checkout fbeb040523028b5f1f4ab24334e6471a794b68f4
cd ccnet
./autogen.sh
./configure
make
sudo make install
cd ..

4) build seafile (includes the seafile-cli):

git clone  https://github.com/haiwen/seafile.git
#just to get the the same version I used (optional)
git checkout 9e1b5a3791a86460a0dc8f7ba0092ebb54dc8545
cd seafile
./autogen.sh
./configure
make
sudo make install

In case seafile command-line interface is enough you are done now ! The docs for seafile-cli are here and you can start it with:

seaf-cli

In case you want the graphical user interface you need to build seafile-client:

git clone https://github.com/haiwen/seafile-client
#just to get the the same version I used (optional)
git checkout cecd90093f680af1533c433d5dd4891c69364668
cd seafile-client
cmake .
make
#and wait another time very long
sudo make install
  • 1
    This worked for me, but the qt4 package no longer exists. Instead I had to install qtbase5-dev, qttools5-dev, qttools5-dev-tools, and qt4-qmake. – David Baucum Oct 3 '16 at 12:26
  • I had to run sudo ldconfig after this in order for seaf-cli to run properly. – Sindarus Aug 4 at 10:43
2

On the Seafile download page there is a link to download a "Seafile Terminal Client" and it's listed for "Generic Linux". Download, and extract the 32-bit option. Since it's written in bash/python, you don't need to compile it.

It doesn't appear that the standard client is supported on the RPi, and I can't find an available source download either. Farther down there's an RPi server edition, but nothing on the site mentions an RPi client.

Edit:

After a little more searching, I managed to find the source download for the client on github. The README at the bottom of the page describes what prereqs to install and how to compile and install the software.

Just installing Qt on the RPi will take a long time, let alone compiling that software. I'd recommend sticking to the terminal client if possible. If it's not, be prepared to wait.

  • Could you check the 'source download' link please? – goobering Jan 28 '16 at 23:18
  • 1
    @goobering: huh, that's weird... Should be fixed now. – Jacobm001 Jan 28 '16 at 23:20
  • now, there is no terminal client for generic linux. – netawater Apr 22 '17 at 8:47
2

There is now a package for this in the Debian Backports package repository. Add the repository to your sources by creating a new file called however you like in the /etc/apt/sources.list.d directory, and inside, write the line

deb http://ftp.debian.org/debian stretch-backports main (if you run debian stretch)

Then run sudo apt update and sudo apt install seafile-gui or seafile-cli.


If you get a GPG error saying that there is no public key for this repository, you can add [trusted=yes] so that the line looks like

deb [trusted=yes] http://ftp.debian.org/debian stretch-backports main

Adding [trusted=yes] will bypass the authentication of the repository, it's not fully safe to do but it's the easiest.

If you don't want to do that, you can also try and install the debian-archive-keyring which provides keys for the debian repositories. Run sudo apt install debian-archive-keyring. But if you're running raspbian (most likely), you may get the message Note, selecting 'raspbian-archive-keyring' instead of 'debian-archive-keyring' indicating that apt is installing RASPbian-archive-keyring which we don't need... That's not nice :c. So I suggest you install it "by hand" by getting the .deb package from here, and then runnning sudo dpkg -i pkg_name.deb. Do sudo apt update again and the gpg error should be gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.