0

I was looking for a project for my RPI2 and found a webpage that shows you how to transform your Pi into a wireless access point. Sounds fun, right?

Well, I've done all of the steps and believed I was ready to rock with this project. However, the problem I'm getting is that the guide was made for people with a specific WiFi Dongle (the one that adafruit makes) and that's not the one I'm using.

Naturally, since I'm using an RT5730 from Ralink, I thought I just needed to edit the "driver" setting in /etc/hostapd/hostapd.conf with my driver's chipset, RT5730. It didn't work, though, and I've been trying for about half an hour to get some name that actually works. So, all I need to know is what to write inside of the "driver" section. Any help is greatly appreciated.

EDIT: Here are the contents of the "hostapd.conf" file:

interface=wlan0
ssid=RPi
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=3
wpa_passphrase=myownkey
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
driver=nl80211
ieee80211n=1
hw_mode=g
1

Use nl80211 in your driver settings.

driver=nl80211
| improve this answer | |
  • Nope, still gives me the error:Configuration file: /etc/hostapd/hostapd.conf Line 12: invalid/unknown driver 'nl80211' 1 errors found in configuration file '/etc/hostapd/hostapd.conf' – Alexandre Voloch Jan 30 '16 at 12:38
  • @AlexandreVoloch Can you edit the question and add the entire contents of /etc/hostapd/hostapd.conf? – PNDA Jan 30 '16 at 12:39
  • @AlexandreVoloch I don't see anything wrong with it. What's your OS? (Raspbian? Arch? Something else?) – PNDA Jan 30 '16 at 12:56
  • The OS I'm running is Raspbian off of the NOOBS installer. With Raspberry Pi 2 B. The WiFi dongle I'm using is the one off of canakit.net (where I bought my kit from). I've tried to get my other WiFi dongles working, but to no avail. – Alexandre Voloch Jan 30 '16 at 13:01
  • @AlexandreVoloch Have you tried removing the line? – PNDA Jan 30 '16 at 13:04
0

You need a custom hostapd - see tutorial

Details: Hostapd contains just "too standard" drivers inside it's distribution, so there are additional "add-ons" to the source tree, that leaded to some forks. Theese forks are working as usual in common cases, and in their specific cases they're working differently. For your case you need to try this realtek-specific fork

| improve this answer | |
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Jacobm001 Jan 31 '16 at 3:14
  • @Jacobm001 OK, I'll fix it tomorrow – Alexey Vesnin Jan 31 '16 at 4:25
0

What finally worked for me was that I had to use different hostapd binary:

sudo /usr/sbin/hostapd -d /etc/hostapd/hostapd.conf

Both builtin chip and DWA-125 worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.