2

I bought a Hama 00053224 Keypad and I want to use it with my raspberry pi to easily enter digits. Is there a way to install or configure a driver for it on raspbian jessie?

Because nothing happens if I just plug it in. If I try it on my mac book, it works fine without configuration.

lsusb output (I have a Canon printer connected too):

Bus 001 Device 004: ID 04a9:1772 Canon, Inc.
Bus 001 Device 008: ID 05a4:8003 Ortek Technology, Inc.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Its Bus 001 Device 008: ID 05a4:8003 Ortek Technology, Inc.

I also tried capturing input with python-evdev. I can see the keypad:

>>> from evdev import InputDevice, list_devices
>>> devices = [InputDevice(fn) for fn in list_devices()]
>>> for dev in devices:
...  print(dev.fn, dev.name, dev.phys)
...
('/dev/input/event1', 'Keypad USB Keypad     ', 'usb-3f980000.usb-1.5/input1')
('/dev/input/event0', 'Keypad USB Keypad     ', 'usb-3f980000.usb-1.5/input0')

But nothing happens if I try to capture the input.

EDIT

I'm pretty sure it has to do with numlock. Because I can see the same stuff as Peter here https://unix.stackexchange.com/questions/123527/targus-usb-number-pad-not-working-in-debian-wheezy But I don't know how to change numlock setting. I tried uncommenting LEDS=+num in /etc/kbd/config but it does not work either.

EDIT II

I also tried with setleds (I'm pts over ssh):

pi@raspberrypi:~ $ who
pi       tty1         Jan 31 10:40
pi       pts/0        Jan 31 10:42 (192.168.88.214)
pi@raspberrypi:~ $ sudo setleds -D +num < /dev/tty1
pi@raspberrypi:~ $ sudo setleds -D -num < /dev/tty1 

But it does not work either :(

EDIT III

Tried with another keyboard with numblock on it. Uncommenting LEDS=+num in /etc/kbd/config works. It just doesn't have any effect on my usb keypad. But it's necessary to get the numbock working after boot.

dmesg output is btw:

[    4.319902] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.319928] usb 1-1.5: Product: USB Keypad
[    4.319937] usb 1-1.5: Manufacturer: Keypad
[    4.326725] input: Keypad USB Keypad      as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0/0003:05A4:8003.0004/input/input2
[    4.373508] hid-generic 0003:05A4:8003.0004: input,hidraw3: USB HID v1.10 Keyboard [Keypad USB Keypad     ] on usb-3f980000.usb-1.5/input0
[    4.381664] input: Keypad USB Keypad      as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.1/0003:05A4:8003.0005/input/input3
[    4.433868] hid-generic 0003:05A4:8003.0005: input,hidraw4: USB HID v1.10 Mouse [Keypad USB Keypad     ] on usb-3f980000.usb-1.5/input1
  • It is a USB number pad; it may work simply by plugging it into your Pi. These usually present as an HID or keyboard to the system and don't require a driver. – Steve Robillard Jan 30 '16 at 11:20
  • Hi Steve, I thought that too, but it does not work :( – sspross Jan 30 '16 at 11:29
  • Have you tried it in another computer? What does lsusb show after plugging it in also, can you edit your question and add the output of dmesg? – Steve Robillard Jan 30 '16 at 11:31
  • Thanks for your help, I just did. I also tried different usb ports – sspross Jan 30 '16 at 11:35
  • to rule out the oobvious have you toggled num locks? – Steve Robillard Jan 30 '16 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.