1

I am trying to install openCV 2.4.9 on raspberry pi 2 but facing some error regarding libtiff4-dev image format.

enter image description here

I have tried with 'libtiff5-dev' also but it is not working.

enter image description here

I dont know what the issue is, I installed same openCV in my other micro SD card 3-4 month before that time it worked fine.

I have already install python 2.7.9.

I have tried searching for this error but was not able to find a solution, can anyone help me? Tell me what wrong I am doing here.

Thanks in advance.

  • If you are using jessie, what's wrong with just apt-get install opencv? 2.4.9 is the current version. – goldilocks Feb 1 '16 at 17:35
2

As per this askubuntu question. You need to do:

sudo apt-get update

before attempting to install it. If this still does not work you may need to add the repository that libtiff4-dev comes from, but it could be that libtiff4-dev is no longer included in any repositories, in that case, you may be out of luck.

UPDATE:

I just did sudo apt-get update on my Pi and then sudo apt-get install libtiff4-dev and I was able to install it, so it is still in the repo.

  • Yes I have tried with 'sudo apt-get update' and 'sudo apt-get upgrade' but still it didn't worked. – shivam Jan 31 '16 at 3:32
  • I am doing this as I have to install openCV, I am following pyimagesearch.com/2015/02/23/… this link – shivam Jan 31 '16 at 5:36
  • I am using raspbian Jessie version. – shivam Jan 31 '16 at 7:49
  • Those instructions look to be an incredible waste of time since openCV is in the Raspbian repos, as is a python-opencv (2.4.9) package. – goldilocks Feb 1 '16 at 17:42
1

To fix unmet dependencies, use sudo apt-get -f install

If it doesn't worked out then try with aptitude

sudo apt-get install aptitude

sudo aptitude install <Your_package>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.