2

My Pi gets stuck on boot-up with the message "A start job is running for LSB: Raise network interfaces (timer / no limit)". The timer keeps counting up, bot the job never completes, and thus the Pi never finishes booting. How can I abort this process so that the Pi continues booting?

Backstory: I'm running Raspbian Jessie on a Pi B, and after the first successful boot, I wanted to configure the wifi dongle for my home network. Since the home network does not broadcast its SSID, I couldn't use the Network Prefs UI. I tried editing some config files, but now the Pi is stuck on boot.

  • Have you tried pressing the esc key? – joan Jan 31 '16 at 0:12
  • 2
    @joan - Yes. Esc does not stop the timer or the asterisks. – KatieK Jan 31 '16 at 0:33
2

If you connect ethernet it should work. You'll need to make sure that the file, /etc/network/interfaces, has the line auto lo iface lo inet loopback.

1

I found that pulling my wifi dongle allows the Pi to boot. My problem stems from having to have 2 setups, one for school, the other for my out dated home network. Since my wifi can't connect until I enable it, it hangs. A poor work around, but its what I am currently working on, hope it helps.

  • Welcome to the Raspberry Pi part of the Stack Exchange. Any chance that you can update your home network? 8-) – SlySven Feb 3 '16 at 20:15
0

I discovered that I can improve boot time by disabling dhcpcd (DHCP client that was doing DHCP Discover on all interfaces). Use this: sudo systemctl disable dhcpcd

FYI: dhcp client will still work on a per-interface basis according to /etc/network/interfaces which may contain an entry such as "iface eth0 inet dhcp"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.