-1

I'm trying to get the 3.5"spotspear Waveshare display working following the guide, (can't have more than 2 links,the name of the guide is "I'd like to have some LCD on my Pi")

Problem is that when I'm using the modprobes the guide suggests

pi@raspberrypi ~ $ sudo modprobe flexfb nobacklight regwidth=16 init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320
pi@raspberrypi ~ $ sudo modprobe fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24

everything works, but as soon as I reboot the screen goes blank.

In the /etc/modules I've put both the commands.

There is no HDMI attached, I'm using ssh to write to the console.

Update: This guide it's maybe easier to read,I've tried using the modules it suggests which don't seem that different,but still nothing.

I've also tried downloading and installing the spotspear drivers but upon reboot the screen is still white.

The modprobes from ssh work fine,but the screen is still white after boot.

  • 3
    What modprobes? Perhaps you are following an out of date tutorial. – joan Feb 1 '16 at 17:22
  • These two: sudo modprobe flexfb nobacklight regwidth=16 init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320 – user40852 Feb 1 '16 at 18:41
  • and : sudo modprobe fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24 – user40852 Feb 1 '16 at 18:45
  • @joan - For neatness, I've added the modprobe lines to the original post. Do note that you do not put the sudo modeprobe ... lines into /etc/modules, you put the flexfb... and fbtft_device... lines into /etc/modules, as the guide shows. Have you added the former or the latter lines? – Greenonline Feb 1 '16 at 19:15
  • I didn't include "modprobe" in the /etc/modules – user40852 Feb 1 '16 at 19:23
0

In the /etc/modules I've put both the commands.

You only need to list the modules themselves (with any options passed to them in /etc/modules.

So it should look something like:

flexfb nobacklight regwidth=16 init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00‌​,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x‌​0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,‌​0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x2‌​4,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320 
fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24
  • Sorry , I don't know the terminology well but I put the right lines in the right places, I didn't include "modprobe" in it,but at boot the screen is still white. – user40852 Feb 2 '16 at 13:17
0

I found a clunky solution that will have to do for now,I created a bash script with the modprobes in it which executes on startup in /etc/rc.local.

It does look seamless though.

0

There are four different stages/places/ways of modules auto-load, and let me explain them :

  • kernel command-line. It's a must-have modules, from statically linked to kernel or from statically-linked into kernel initrd. There *must be** your storage controller's drivers, NIC drivers, hardware crypto and firewall things. Theese modules can not be unloaded.
  • kernel command-line from initrd(bad practice sometimes). Something you need to be up early, like your USB wifi dongle to make your home AP working, e.t.c.
  • /etc/modules.conf - some non-vital peripherials, like an external TFT/LCD i2c display, i2s sound card - all that can be safely initialized after mounting all the file systems, including network ones.
  • rc.local post-init script. Yes it is! I had a very odd problems popping out of nowhere from time to time when I was trying to use ZRam module as a swap provider. Until I removed any swap from /etc/fstab and added it in rc.local after all the things are already up and properly configured.

So - the main part - none of the levels mentioned upstrings are extra, not one of them is replacing another, all are good for their tasks. Do not try to replace them to ensimplify things - you will be very disappointed by the glictches like I used to have with ZRam.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.