0

After trying to open netsurf through LXDE it didn't work so I tried typing netsurf into LXterminal but then it just started saying "segmentation fault" after every command I ran. I tried to reboot the raspberry pi by pulling the cord out of it because the reboot command wouldn't work either. Now it won't start up at all and nothing is being output to HDMI and the usb ports aren't functional.

  • This indicates an error in an application. Generally to only option is to restore the SD card from a backup or perform a new installation. If you can get to the command line you may be able to repair with sudo apt-get update & sudo apt-get upgrade` – Milliways Feb 2 '16 at 0:31
2

The cause is likely some kind of filesystem corruption or a nasty mistake involving sudo (don't pull that trigger unless you know what you are doing). A segmentation fault is a memory access violation; if multiple different applications are doing this is it is because of something that happened to a common shared component that was obviously working not long before.

You can try taking the SD card out and running e2fsck on the second partition from another system (linux or something else which supports this). That may not solve the problem, but it could allow you to get data off it if you need to.

You will probably have to re-install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.