1

I got this error while trying to deploy hello world example on my Raspberry Pi

Error : DEP0700 : Registration of the app failed. Windows cannot install package HelloWorld because the package requires architecture ARM, but this computer has architecture x64. (0x80073d10) HelloWorld

I have followed the instructions from HERE

I had the authentication mode set to Universal (Unencrypted Protocol), but then it asked me to enter a PIN (?), but then I changed it to none. I have set the target platform to ARM.

2
  • 2
    I am NOT even an amateur with IOT on RPi - but that error message sounds like you are trying to deploy (install and operate) the App on the Windows Host machine (with the x64 architecture) and NOT the Raspberry Pi target (which is has an ARM CPU)...! It sounds like the step 2 in that guide has not take effect (change from "Local machine" to "Remote machine"). – SlySven Feb 2 '16 at 18:14
  • Apparently there was an update that changes something with the authentication. I'll report back after I set it up. – CodeBreaker Feb 2 '16 at 18:27
1

The solution was updating to the latest version of windows iot 10.0.10586 (at the time od answering this).

In previous builds of the Windows 10 IoT-Core, MSVSMON was included in the image and running by default. When you deployed/debugged an app from Visual Studio 2015 to IoT-Core device you set the authentication to NONE and your VS interacted with your device as a Remote Machine. With Build 10586, MSVSMON is not included in the image and so it needs to “bootstrapped” at deployment/debug. This means it is deployed before the app is downloaded each time. This change has been made because IoT-Core OS development kept running into issues as “Big Windows” evolved. IOT-Core leverages SSH to “bootstrap” MSVSMON To perform this bootstrap NONE authentication can’t be used. You need Universal ( Unencrypted Protocol)

Source: http://embedded101.com/Blogs/David-Jones/entryid/721/Win-10-IoT-Core-Visual-Studio-2015-Update-1-App-Deployment-and-Debug-Requirements

0

The linked article in the accepted answer was spot on thanks, with one exception - in the new version of the Device Portal for IoT I could not find the Process tab in order to kill MSVSMON. Instead select the Launch Powershell option in the IoT Dashboard, then followed the commands provided here: IoT Core Command Line (tlist.exe, kill.exe [pid or process name]).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.