4

I am trying to use sixaxis to connect a ps3 controller to my Raspberry Pi. When I run sudo ./sixpair_rpi, I get:

Current Bluetooth master: xx:xx:xx:xx:xx:xx Setting master bd_addr to xx:xx:xx:xx:xx:xx

which does exactly what it is supposed to do; setting the bluetooth dongle and the controller to the right connection. However, when I run sudo ./start_rpi (I'm using HR-OS1 Framework from GitHub), the controller will wait an eternity and never connect. Does anyone know how to troubleshoot this?

I am working with a Raspberry Pi B+ running Raspbian Jessie with an ArbotiX Pro CM-730 Microcontroller. My source code is HR-OS1 Framework from GitHub. My bluetooth dongle is a CSR V4.0.

3
  • did you pull the latest code? try a stable release perhaps? – Havnar Feb 3 '16 at 14:32
  • Welcome to the Raspberry Pi Stack Exchange community. Do you have robotic hardware (now that's an odd thing to have to ask!) - or are you merely using bits of the code to work a PlayStation 3 controller. Can you add URLs to the micro-controller and to the HR-OS1 framework (is the latter this one)? Though it does not explicitly list RPis as a supported platform... – SlySven Feb 3 '16 at 19:49
  • @SlySven It is unusual that I'm using the controller with a robot. Most of the help I've been looking at online are for games and what-not. Tbh, I'm not really sure what the CM - 730 does (Link here). I'm just following the instructions on the HR-OS1 Wiki without much beforehand knowledge of Raspbian and Linux. – Fredenburger Feb 4 '16 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.