0

First of all I want to say I'm new to linux in general so this might be something really simple. My issue currently is trying to make it so both my apache and samba autostart on boot. I've been trying follow some wheezy guides but I'm thinking this might be different in jessie (im running jessie) so someone told me about webmin to easily fix this and I installed it but it didn't really fix my issue. https://i.gyazo.com/ad70757d1a35167d2eddb28005e6b271.png That's what the panel looked like and apache2 and both smbd and nmbd were set on 'No' on "start at boot?" so i changed them and rebooted but it didn't really fix it. this is what the module options look like: https://gyazo.com/9ae9670818bb4045cfa4a7446d2dcc2d maybe I'm supposed to change something so it works for raspberry pi? I'm thinking maybe its something with the boot system options? http://i.imgur.com/eu8uefw.png

when it detects automatically it sets it to upstart, is this what's used in raspbian or am I supposed to use something else?

Thanks in advance and I'm sorry if this has already been answered, couldn't really find anything that answered my question.

2

In Jessie, there is a demon program called systemd that is responsible to starting most of the major subsystems and, if those subsystems are not already known to systemd they can be easily added. Here is a tutorial video on setting up programs to start at boot time:

https://www.youtube.com/watch?v=eEuViHanjKI

If your services are already registered to systemd but not configured to start at boot time, try running the command:

$ sudo systemctl enable <serviceName>

If you don't know what services are registered with systemd, try:

systemctl list-units | more

There is also a lot of literature available by googling on systemd itself.

  • pi@raspberrypi:~ $ sudo systemctl status apache2 Failed to get D-Bus connection: Unknown error -1 pi@raspberrypi:~ $ sudo systemctl list-units | more Failed to get D-Bus connection: Unknown error -1 I get this error when trying to run those commands, any ideas to what could be causing it?, the enable command seemed to work though but after reboot stuff is not autolaunching :/ – Cotta Feb 7 '16 at 10:48
  • if I make a .service for apache, what would I input in the ExecStart= part? – Cotta Feb 7 '16 at 11:02
  • I did a google search using "systemctl apache" and found lots and lots of hits. This seems to say to me that apache is already systemd enabled and I myself run samba which I know is systemd enabled. It is starting to feel like there is something broken in your configuration. What I'd suggest is get a second SD card, install a fresh Jessie and then install apache and/or samba and see if they are systemd enabled on that virgin system. – Kolban Feb 7 '16 at 17:00
  • For some reason I had installed upstart on my raspberry pi and this was messing with my systemd, I uninstalled it and now it works fine :) – Cotta Feb 21 '16 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.