1

I foolishly rolled back my firmware so that I could install MySQL, because some tutorial told me to do so. I am usually good about not messing up that bad.

Anyway, once I rolled back my firmware, I rebooted my Pi and it only showed the rainbow splash screen for a second, then the screen turns off. I waited for the entire night and nothing happened. I Googled it, and most articles said reinstall Raspbian. I decided I needed to start over and reinstall Raspbian on the SD card, and at that point I hit the second problem. The SD is recognizable by OS X and Kali linux, but it is read-only, therefore not allowing me to use DD, gparted, fdisk, or Disk Utility to erase the SD card. I tried using dd if=/dev/zero of=/dev/theindentifierofthesdcard bs=somenumber, regardless of what OS I was on, it still said "Permission Denied". I also tried sudo chown -hR username /dev/SDIdentifier, yet it still didn't help.

I used this command to roll back my Pi: sudo rpi-update f6eef32dd6388c3b04dbf462bd324d93281bf397 and I got that command from this site: http://raspipress.com/2014/06/tutorial-install-mysql-server-on-raspbian/

This SD card is 64GB and was not cheap, I refuse to purchase a new one.

My question(s) is/are this:

  1. Is there a way I can boot the Pi past the Splash screen and run sudo rpi-update to fix the firmware issue?
  2. Is there a way I can totally erase the micro SD card so I can install Raspbian again?

Specs: Raspberry Pi 2

64GB SanDisk Ultra Micro SD

My OSs:

Kali Linux

Mac OS X 10.11.3

I have Windows 10 as well, but didn't try it.

closed as off-topic by goldilocks Feb 7 '16 at 11:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be specific to the Raspberry Pi within the scope defined in the help center." – goldilocks
If this question can be reworded to fit the rules in the help center, please edit the question.

  • if you want to reset it anway, why don't you just format it and load a fresh image? – dube Feb 6 '16 at 22:58
  • @dube , that's just my problem, it won't let me format it – Ryan Feb 6 '16 at 22:59
  • How do you insert the microSD into your Mac? – techraf Feb 7 '16 at 0:23
  • Through an adapter to convert it to normal SD card size, then I plug it into another adapter in order to insert it into my Mac Pro via USB. That isn't the problem, cause I've tried it on multiple computers – Ryan Feb 7 '16 at 0:54
  • 1
    Not being able to erase an SD card is not really a pi related issue. You seem to be saying you cannot write anything to it no matter what the data is or what hardware or OS you use. I recommend you try our larger sibling Super User instead. – goldilocks Feb 7 '16 at 11:43
1

The SD card has an internal flag which indicates it is RO, but this is not enforced - it is up to software to honour this (which most OS do).

Your best option is to download the formatter from the SD Foundation. See:- https://members.sdcard.org/downloads/formatter_4/

Not the answer you're looking for? Browse other questions tagged or ask your own question.