I have a Raspberry Pi 2 and a LCD

I have no problem with LCD but i want to switch HDMI for video output . i tried to add these line to config.txt :


but i can't use HDMI even by those codes

anyone have idea? i used raspberry pi about two years ago and i can't remember how to fix this

Update: I used this question before

  • Are you editing the /boot/config.txt file? If so, it should work with only the following changes: hdmi_force_hotplug=1 use HDMI mode even if no HDMI monitor is detected<br> hdmi_drive=2 set to normal HDMI mode (with sound if supported and enabled) If your HDMI monitor doesn't support sound, try setting hdmi_drive=1 since it's possible that the RPi's protocol communications over HDMI with your monitor are determining that sound is not supported and the RPi is disabling the HDMI output.
    – BartmanEH
    Feb 7, 2016 at 21:50
  • You didn't specify exactly which file you were editing. Are you editing /boot/config.txt ? I'll edit my answer to provide more suggestions.
    – BartmanEH
    Feb 7, 2016 at 21:56
  • Are you using NOOBS?
    – joan
    Feb 7, 2016 at 22:32
  • 1
    Possible duplicate of How do I force the Raspberry Pi to turn on HDMI? Feb 8, 2016 at 7:18
  • 1
    NOOBS is a bit funny (I don't use it). Check its documentation for how to edit the correct config.txt. I believe you have to hold the shift key down during boot to get the recovery screen. There should be an option to edit the correct config.txt from that screen.
    – joan
    Feb 8, 2016 at 10:21

1 Answer 1


Try playing with con2fbmap 1 1 or (play with 0 and 1 ones for console.

For starting X, if you used config with multiple layouts e.g. /etc/X11/xorg.conf.d/fbtft.conf (like http://pastebin.com/3wdEU9hw ), you can use sth like startx -- -layout hdmi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.