0

I have bought a Raspberry PI 2 bundle, which contained an Edimax ew-7811un wifi stick. Unfortunately it is not working well with the Raspbian OS. It is horribly slow (4-10 Kbyte/s). I have tried several solutions and nothing worked.

I tried with Ubuntu Mate, there it got always disconnected after a while.

Can you recommend any USB Wifi Stick which:

  • you have used and works fine
  • has a speed of ~150Mbit/s
  • there is no struggling with setting it up with Raspbian
  • if it also works with Ubuntu Mate it would be great.

Size is not that critical, so it can be also something bigger than the Edimax. If there is some setup process of the stick, please refer to some install guide if there is any.

5
  • 2
    That Edimax adapter is just about the most commonly used USB wifi dongle for the Pi. It's really well supported. If it's not working then it's plausible something is wrong with your underlying system, or that there are external factors causing WiFi problems. If that's the case, a new WiFi dongle is unlikely to help.
    – goobering
    Feb 10 '16 at 9:58
  • I tried with the original raspbian coming with my bundle. I plugged in my dongle, attached to my wifi, and its slow like hell. Not sure what I did wrong. Feb 10 '16 at 10:10
  • It can be tricky to diagnose. I'd strongly recommend a careful look over all of the elements of your system, and some basic tests of your existing adapter.
    – goobering
    Feb 10 '16 at 10:20
  • Possibly an insufficient power supply related issue? I've seen many questions about USB Wi-Fi not working as well as expected, and often it is due to the additional power drain on the PSU by the USB Wi-Fi stick. What is the curent capacity of the PSU that you are using at the moment? Maybe try using a larger (i.e. greater current capacity) power supply? Test the stick in a laptop, as see if it as slow as it is when used with the Pi. Feb 10 '16 at 10:42
  • So it seems that it is also horribly slow with my Windows 10 desktop. It must be a defect. Feb 18 '16 at 22:39
1

Like a comment mentioned, it's either your system or your environment. Or, you simply got a bad stick.

Here's a checklist on what to look for:

  • Interference
    • baby monitors, a buttload of nearby WiFi hotspots, microwaves, anything using the 2.4 GHz spectrum)
  • Error messages (dmesg is a good place to start)
  • The environment itself
    • Is your WiFi device and your Access point behind a block of lead? If it is, you have a problem.
    • A lot of walls (or floors if in a multi-story building) will definitely hamper signals to the point that both devices agree on using a very low-bandwidth connection.
  • The stick
    • Does it work properly when used on your PC or laptop? (in a radio-quiet location, like in the woods/beach)

I can't really diagnose it with your given info. Some configuration details and error messages (if any) would be helpful.

0

The edimax dongle did not show more speed in a windows 10 machine as 1 Mbps. So I think it was defect.

I have bought however Asus N10 Nano dongles, and I can confirm, that it works out of the box with Windows 10 on PC, witn Raspbian and Ubuntu Mate on Raspberry 2.

0

You can also try WiFi sticks with Ralink Chipsets for instance RT5370 series based LogiLink WL0145

They work perfectly with Raspberry Pi 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.