2

We use several Pis for signage.

The usage is simply full screen browsers pointing to a web page that rotates images every X seconds (done via JavaScript with fades, etc. provided by jQuery; 1920x1080 images).

We were/are using several Raspberry Pi 1B+'s in combination with Chromium, and things worked fine.

Then we got the Pi 2s, and have had no luck with browsers.

With Chromium:

After the first or second slide is shown, suddenly the next (and all following) slide is shrunk to (the left) half the screen. if it rotates through them all, back to the original one that worked, it's not half the screen as well.

The mouse pointer will move onto the right, "blank" side, so that half of the screen is still active.

Simply hitting F5 to refresh the browser once seems to fix it indefinitely, until after the next reboot, when things repeat as described.

  • We tested it off and on for a couple months (doing updates each time, etc.), and the problem remained.
  • Tried turning off the theme(s) - no help.
  • Tried multiple PI2's, same problem.
  • Reinstalled Raspbian from scratch and setup everything by hand more than once, trying different SD cards as well, same problem.

  • Launching the browser in windowed mode instead, seems to work fine indefinitely.

With Epiphany and KWeb:

Decided that perhaps using a Webkit3 browser would give us better results.

With both Epiphany and KWeb the browser will start and do it's thing, but then as some random(?) point the browser will just vanish from the screen, showing the desktop (which looks and works fine). Sometimes its within a couple minutes, sometimes it seems to last hours.

Settled on continuing testing with KWeb.

  • Trying the Webkit2 version didn't help -- same problem.
  • Using Memory Split settings to give more memory to the GPU doesn't help.
  • Ensuring all overclocking is turned off -- same problem.

When it vanishes, it doesn't appear to actually be crashing:

  • I can't find anything related to it in /var/log (no mention of "KWeb", no mention of its process, no mention of the kernel killing it because of memory consumption or alike, nothing that seem related happens at the approximate time it vanishes).
  • The KWeb process is still running (and can be killed from a terminal instantly, and without complaint).

Other bits:

  • We were using a jQuery plugin to do the image rotation (jQuery cycle).
  • Ensuring it's the latest version didn't help.
  • Made a new test HTML page that just uses jQuery fades, with my own timers, etc. instead of the plugin -- same problems.
  • We were using jQuery 1.4 on the site, setup the new test page to use jQuery v2.2 (latest right now) instead -- no difference.

So, any ideas on what the heck is going on, or what else I can/should be looking at/testing to figure it out?

  • Quick sanity check: have you tested the pages on a non-Pi platform? Do they behave any differently? – goobering Feb 10 '16 at 16:57
  • @goobering Thanks for the interest. They work fine with Pi version 1 (B+), as they have for months. And in testing with Windows PCs (IE11) they can view it non-stop (tested for a couple days straight, a couple times) no problem. I have yet to have a PI 2 keep a proper browser window open for overnight. :/ – techie007 Feb 10 '16 at 17:15
  • 1
    This is me swinging in the dark, but there's a new Raspbian release as of yesterday that incorporates an 'experimental OpenGL driver for the desktop'. I am unsure whether Chromium will be able to make use of this driver, or whether it will impact on your issues. It may be worth a punt. – goobering Feb 10 '16 at 17:34
  • I'm working with Pi2's for signage atm too, also no luck with browsers. My biggest problem with chromium is memory usage. Also using plain javascript to go through images, have you watched your mem usage? Epiphany ran fine tho for a complete night. I did notice that using javascript/jquery on the pi has horrible performance, but it does work on pi1 on your end apparently? – Lonefish Feb 11 '16 at 8:58
  • 2
    Thx for the suggestions so far folks. :) @goobering's mention of the recently released OpenGL package got me checking, as I had performed an apt-get update, etc. on that day, but I wasn't sire if I got that package. While checking, it dawned on me that we are still using Wheezy. I rebuilt the Pi from scratch using Jessie, and I've just started testing it again. If it runs for all day and night, then I think I've found my answer (fingers crossed). I'll be back to update this with my findings. – techie007 Feb 11 '16 at 17:02
0

@goobering's mention in teh comments of the recently released OpenGL package got me checking, as I had performed an apt-get update, etc. on that day, but I wasn't sure if I got that package.

While checking, it dawned on me that we are still using Wheezy. I rebuilt the Pi from scratch using Jessie and began testing, using the minimal web page I had created for testing.

It lasted a full day without incident.

I changed it back over to using our original website for signage, rebooted and continued testing. It lasted over the long weekend, without incident.

Rebooted it again and now another 2 days later it's still functioning as expected.

Apparently there's something in Wheezy that just doesn't jive with the Pi-2s.

Specifically with the Pi 2 Model B v1.1s at least anyway. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.