A friend lend me his old Raspberry Pi to try it out. Currently I am trying to install GitLab on it.

I followed the instructions from their install page. Even though it is stated that those instructions are for the Raspberry Pi 2, everything seemed to work fine. I was greeted with a success message after unpacking the image:

gitlab: GitLab should be reachable at http://raspberrypi
gitlab: Otherwise configure GitLab for your system by editing /etc/gitlab/gitlab.rb file
gitlab: And running reconfigure again.
gitlab: For a comprehensive list of configuration options please see the Omnibus GitLab readme
gitlab: https://gitlab.com/gitlab-org/omnibus-gitlab/blob/master/README.md
It looks like GitLab has not been configured yet; skipping the upgrade script.

After that I tried to connect to the Gitlab install from another computer on the same network, but neither the Ip, nor http://raspberrypi works.

I checked the external URL setting and tried sudo gitlab-ctl reconfigure, that takes a second or two, but there is no success message or error after doing that, I just can’t connect to the Gitlab installation.

gitlab-ctl status does the same thing. I wait for several seconds, but I get no message at all.

Is there a way to get Gitlab to work on the Raspberry Pi 1?

  • Welcome to the Raspberry Pi flavoured corner of the Stack Exchange Network. I think your issues are down to the stated requirements my reading of those suggests this application likes to have more than one core and 1GByte of real memory to play in and the RPi 1s just don't come up to that mark (though the latter may be offset by swap space - which on an RPi is the same as the data storage space, i.e. the SD Flash Card). This may explain the lack of response as web-requests are handled by server-processes running on other cores... – SlySven Feb 11 '16 at 20:16

I had trouble running gitlab on 2 GB RAM 1.2 GHz HP ProLiant. It uses a lot of resources to run. If you can do without the fancy GUI, you could just install the git core on your RPi create a bare repository that you can then push to just like you were using github or gitlab.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.