0

When using my Raspberry Pi, my camera stopped working and I get the following error. Error For those who cannot read it, it says:

Traceback (most recent call last): File "_ctypes/callbacks.c", line 277, in 'calling callback function' File "/usr/lib/python3/dist-packages/picamera/camera.py", line 129, in _control_callback "Received unexpected camera control callback event, Ox%08x" % buf[0].cmd) picamera.exc.PiCameraRuntimeError: Received unexpected camera control callback event, 0x4f525245 Traceback (most recent call last): File "/home/pi/Desktop/turflnl.py", line 49, in camera.capture('test.jpg') File "/usr/lib/python3/dist-packages/picamera/camera.py", line 1575, in capture 'Timed out waiting for capture to end') picamera.exc.PiCameraRuntimeError: Timed out waiting for capture to end >»1

Upon research of this question, found the following link, where a comment states that the error is static electricity damage. I find this unlikely, seeing that the camera was in a case and I did not touch the camera for some time. I found this post on the Raspberry Pi Foundation Website, which states:

Also note, this experimental driver may break Raspberry Pi Camera and video playback support, and perhaps other GPU functionality.

I also found this thread on the Element 14 forums. Which links to here, which lists instructions I do not know how to do. If anyone could tell me which commands to type in the terminal, that could be great. On this forum post, I followed all the commands that were provided, with no resolution. What can I do to get my camera functional again?

Edit: I do not have OpenGL enabled on my Raspberry Pi.

  • That comment only relates to the opengl and you should be able to turn it off in raspi-config. For future reference ALWAYS make a backup before a major update. I think there was even a warning in the post. I always backup before any update, because sometimes things can go wrong, even if there is nothing wrong with the update. PS I didn't read your error - because it is too small. Always pase as text not an image. – Milliways Feb 13 '16 at 6:13
  • @Milliways I do not have opengl enabled, I thought that the way that it was worded was that the new release may not support raspicam. – Human Feb 13 '16 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.