0

I have a raspberry Pi B that I would like to configure for sound. It's running ubuntu 14. I just installed PulseAudio and unfortunately there is no sound. I have tried this several ways.

If I run:

play something.wav - No Sound

player something.wav - No Sound

aplay something.wav - Sound!

I also have the test program from Pulse Audio recording on the sink. When I run the top two commands I see bytes from the recorder. The bottom one nothing shows up. How can I get pulse audio to work?

0

I've had good luck getting sound to work using pavucontrol, and turning the output on from there, where other systems do not work.

0

I finally figured this out no thanks to google. It was a permissions issue. I needed to install pulse audio as root and run in system mode. (This isn't recommended for future readers) but for the raspberry pi I think it is the way to go. Once it was installed as root I needed to add root and my user to the pulse and pulse-access groups. Then everything works as expected.

-1

uninstall alsa : only one of them is working at the same time, see official website and an official diagram. Alsa interface can be enabled, but it's not a basement for PulseAudio at all, FYI

  • Pulse works on top of alsa. – nbroeking Feb 15 '16 at 16:18
  • @nbroeking you are wrong, see my update – Alexey Vesnin Feb 15 '16 at 16:53
  • I appreciate your update. You are right that PulseAudio does not need alsa but it needs some driver layer. Ubuntu used to use Oss (pulse audio does support) but unfortunately my version of ubuntu I am using used Alsa as the audio drivers. I ended up discovering that pulse audio had the wrong permissions and thats why it wasn't working. I understand the confusion though. There are several great textbook on drivers versus daemons out there if you need. On an unrelated note I never down voted your answer so unfortunately your down vote is from someone else and not me so I can't give you that back – nbroeking Feb 15 '16 at 23:36
  • @nbroeking I'm glad that it works now! And it was not all about a downvote : I used to have such a weird experiences with ALSA, ended up with pulseaudio compiled from source – Alexey Vesnin Feb 16 '16 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.