6

I recently purchased a Raspberry Pi 2B+, and I am trying to run the RetroPie (backed by raspbian) operating system on it. The first time I plug in the pi, it boots normally into the operating system (normal PWR and ACT activity). Without making any changes, when the pi is shut down it no longer boots up. Reformatting the SD card lets the pi boot once, but then not a second time.

When the pi is booting up the second time, the green ACT light acts as normal for about 30 seconds, then pulses once a second for a few minutes before turning off for good. The PWR light stays lit the entire process.

I have tried the process with two different SD cards,

  1. Sandisk 8GB Class 4 microSD

and

  1. Samsung 32GB Class 10 microSD.

Does anyone have any suggestions? I don't know if this is relevant, but when it boots there is a USB keyboard and mouse, USB wifi adapter, and monitor with an HDMI to VGA converter plugged in.

Thanks in advance.

EDIT: Running the reboot command through the terminal boots normally. Also, NOOBS will boot twice, just not retropie.

  • Probably a problem with the Pi. It seems as if shutting it down is corrupting the sd card. How are you shutting the Pi down? – Patrick Cook Feb 13 '16 at 23:51
  • I'm shutting down by clicking the shutdown button in retropie/emulation station. It shouldn't be corrupting the SD card from what I can gather. – Bradley B Feb 13 '16 at 23:55
  • 1
    Have you tried not starting retropie and shutting down with sudo halt? If it is able to boot up again after that, then you may just have a bad retropie image. – Patrick Cook Feb 13 '16 at 23:58
  • @PatrickCook using sudo halt off of a raspbian image still leaves it bootable. I can't not launch retropie, since it boots automatically and I have no way of stopping it. Also, installing retropie from the github source seems to have frozen the pi, with a blank screen? This keeps getting weirder. – Bradley B Feb 14 '16 at 17:13
  • think I have the same problem. i downloaded the image and used win32DiskImager to put it on the SD. then boot up - perfect - transfer roms with the usb method then restarted emulationstation. played some games. shut down from retropie menu. when I boot it second time screen wont even come on ... tried this two times - again transferred the image, first boot is fine, thereafter nothing. – Christiaan Hattingh Feb 28 '16 at 11:01
1

Since you seem to be able to avoid the issue by using the terminal command to shutdown instead of the GUI shutdown, you may have a defective image. Download a fresh copy, or, read here how to prevent the GUI from starting up automatically.

Not the answer you're looking for? Browse other questions tagged or ask your own question.